Pcbnew crashes during netlist read [linux/debian]


#1

Hi there,

I’ve got a problem with pcbnew which I cannot figure out even though I tried for day now to find the reason. Every time when I read the netlist (see dropbox link) pcbnew crashes with the following (for me very none descriptive) error message written to my konsole:

19:38:57: Debug: Loading project ‘/home/christian/Dropbox/projects/avr_prog/a11/3_Hardware_Design/kicad/avr_prog.pro’ settings.
kicad: /build/kicad-ib3tEO/kicad-4.0.5+dfsg1/include/geometry/rtree.h:1643: void RTree<DATATYPE, ELEMTYPE, NUMDIMS, ELEMTYPEREAL, TMAXNODES, TMINNODES>::Classify(int, int, RTree<DATATYPE, ELEMTYPE, NUMDIMS, ELEMTYPEREAL, TMAXNODES, TMINNODES>::PartitionVars*) [with DATATYPE = KIGFX::VIEW_ITEM*; ELEMTYPE = int; int NUMDIMS = 2; ELEMTYPEREAL = float; int TMAXNODES = 8; int TMINNODES = 4]: Assertion `!a_parVars->m_taken[a_index]’ failed.
Aborted

I’m using using Version 4.0.5 on Debian 8.7. Has any one seen this kind of bug before? Or has anyone an idea how to work around this issue??

Many thanks in advance,

BR
Christian

Problematic Netlist


#2

By the way, if someone would like to dig into this, I can share the would project data:

Link to hole project data (schematic, etc)

I’d really appreciate any kind of support…


#3

Has it worked before?
Did you test with a super simple netlist?


#4

Hi,
thanks for your reply. Yes it definitely worked before. On the same system I already did way more complex projects and I never faced a similar problem. Neither during initial board creation nor when redesigning an existing pcb.
In this case I already tried to remove different parts of the circuit to figure out what causes the crash. The result is however strange, because it is not reproducible for me. Sometimes it didn’t work until I deleted the Attiny in the sub schematic (or changed it footprint to DIP), but if I then take the original schematic back and just delete the Attiny it does not work! There must be some combination of things, net names or whatever… I really have no idea any more :frowning:


#5

If it’s reproducible the best idea (if no one else turns up here) is to go to the bugtracker and see if you can get help from the devs.


#6

Similar things happened with me on Windows 10. I did a ‘dry run’ first then unchecked the ‘dry run’ and read the netlist again.
My board was not very complex, still Pcbnew crashed while reading the netlist. When I tried with simple circuits, it did work normally.


#7

Please raise this on bugtracker and try to upload the netlist if possible.
Crashes are usually flagged “Critical”