PcbNew airwire not visible


I am redesigning a board in Kicad 5.0/Windows 10 32bit and I ripped up some nets. I used delete and the selected routed nets became airwires, which is OK. But when I hit DEL on a GND route it simply disapeares; I can’t see the airwire instead! The pins are still connected to GND, they all are selected when highlight the net in Inspect -> List Nets so the netlist is OK. So the only issue is I can’t see the airwires and that’s confusing and can mislead me to think all the board is fully routed.

What should I do so all nets behaves the same?


Maybe you have a ground plane zone which you have disabled so it’s not visible but still provides connectivity?

I have a ground plane, indeed, but it’s not disabled. Shouldn’t I see the airwire even in this case? I’m not sure the ground plane would cover all the areas eventually. Or it will have the required thickness, without thin bottlenecks.

By disabled I meant copper zone visibility was disabled.

Not if ground plane covers those pads, they will be considered already connected and you won’t see the ratsnest (what you call airwires).

If you ripped out all the traces, it most likely will fill everything.


I see your point. The groundplane ties all pand in realtime and if I route something else in the way, only then I’ll have airframes for the inaccessible pads. Cool!


You can see it for yourself if you enable full visibility of copper zones. Top button on this picture:

Copper zones don’t update in realtime because it would be performance killer on big boards. Instead you can manually rebuild them by pressing B. They are also updated on some actions like DRC check and maybe project open/save.

1 Like

DRC has an option to update zones. There is no update on save or open.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.