PCB tracks not solid


#1

Hi,
The tracks on my PCBs are not solid colour, but outlines, so I can see black through them.
How do I make them solid?
Camerart


#2

Tip: icons on the left vertical bar :wink:


#3

Hi P,
And they’re all filled in now:)
Thanks.
C.


#4

I know that this tread is a tad old but anyway, I’ve run into the same problem, none of my tracks are shown as solid… Cant seem to find the right button, what is it that Im missing?


#5

My left side toolbar is expanded compared to yours. I’m on version 5.0.0 .


#6

Oh I see, need an upgrade… Seems like I’m running version 4.0.7 atm.


#7

Even on v4.0.7 there should be a few more buttons. Try to change your monitor resolution or increase the window size (if it is not maximized yet)

From http://kicad-pcb.org/help/system-requirements/

Screen resolution of 1024x768 works but, 1280x1024 or higher is recommended, with at least 16K colors (with 1024x768 some buttons may result hidden but corresponding commands should be reachable via menu anyway).


You might be in luck and these settings can be reached from within the view or preferences menu. (I don’t have version 4 any more so i can not really double check that.)


#8

Not sure why I didnt get the buttons in 4.0.7
switched over to 5.0.1 and they’re there

Picture for future newbies (like myself) :slight_smile: :


#9

If your screen is limited in size you can (at least on macOs), adjust the size of the icons in the preferences; looks like your layer manager button is dropping off the bottom and there would be no room for anything more (like the microwave button).

Am I alone in thinking this is an odd place for the layer button?


#10

This is a new feature in version 5. It works on all platforms. It is intendet to help with screens that have very high resolutions (3000 pixel or highter)
I am not sure if this feature can help with low resolution screens.

This is because version 4 had more buttons. (And has these buttons in a slightly different order)

You still do not have all available buttons. (There should be one more button for the RF toolbar visibility)


#11

I am running KiCad on a MacBook Pro (screen resolution 1200*800), and reducing the icon tile size using this feature helps to fit the whole left-hand toolbar in the screen. Most of the time I use an external display and can avoid this but i noticed that the op screenshot looked a bit clipped. ( and he is also on MacOs)