PCB Trace Antenna (Continuation)

Hi guys,

I have doubts creating/connecting PCB antennas.

My antenna footprint is composed of 2 pads and a polygon connecting them. I think the main problem areises from the short of these 2 pads which have different names.

I just followed what lukebouer said here. but that didn’t work for me. I am using the latest version of Kicad**. I have the same problem with connecting the GND pad of my antenna footprint into copper pour which is connected to the GND.

  • Can’t add negative PAD clearence. PCBNew does not allow me to do that.
  • Adding a second solid, filled area with different priority isn’t working for me. How do the priorities work?
  • lukebouer’s example just shows more than 2 copper pours.

The picture shows the problem. I have a huge GND pad, which I have to connect with copper pour.

This thing should be a simple task. I appreciate any guidelines/ideas/workarounds.
Thank you.

** My kicad version: no-vcs-found-9413793~61~ubuntu17.10.1, release build

Edit: Some fixes in the text.
Edit2: Added a picture
Edit3: Added more information
Edit4: Some fixes in the text.

You would think so, but no. An awkward way of doing it would be using a single pin symbol for the antenna, connecting the antenna pin to the ground in the schematic and have both pads of the footprint numbered the same as the pin on the schematic for the antenna. Select no thermal relief for the big pad. It should work although schematic is going to be misleading.

Thanks @ArtG, I am trying what you said. Using a single pad symbol connected both to the antenna and to the signal path. Then a footprint with 2 pads with the same pin number. Then, I will have 2 pins that will have connections to GND. So should I do something special on layout to fix the connection?

Look what I have right now?

My idea is to have here some guidelines/workouts that everyone can follow, including me. So, if am I doing something wrong. Please guide me.

Also, my footprint can be wrong. My footprint was generated from a gerber converted to a .kicad_pcb then converted to a .kicad_mod footprint.

Check the connection settings for the pad (Shortcut e while your mouse is on top of the pad,).

And redraw the zone (Shortcut B)

Thanks @Rene_Poschl, I am always doing the Ctrl+B, and B, to refill the zone and I always checking the connections. But what I have to check? The thermal relief?

I am currently on mobile so i can’t look but there is something called zone connection. This can be thermal, solid, none or from zone.

Maybe try setting it to solid.

@Rene_Poschl, I also tried many things, your suggestion including. The best thing I could do is to connect the big GND pad (the one on the right on my pictures above) to the GND, but I could not made a solid connection to the zone without clearance. Do you know if my issue is related with an incorrectly zone fill configuration?

Edit properties of your big pad (highlight the pad, hit shortcut E for pad properties), go to Local Clearances and Settings tab, Then in Copper Zones, Pad Connection change it from “From parent footprint” to “Solid”

That should take care of your one issue. The second issue that you have is that now you have your RF line connected to the ground in other places since it is a GND net now. So you need to add a keep out area around you RF path with the properties set to “No copper pour” so it would not make those thermal relief connections to your RF line. It is a good practice to do that around RF line regardless, so you can independently control gap between the RF path and the ground pour and that you have nice clean edges on the ground next to your RF path. Use plenty of ground stitching vias along the path as well.

Cool, I already have the same settings you are describing.

Great I did exactly what you said. Also, thanks a lot for the guidelines about RF layout.

Look what I have now:

So, I am almost there. The last question is:

What I have to change to automatically surround my big GND pad with the copper pour?

See description above. You need to select solid in pad properties. I don’t know how your footprint is created by keep in mind that it may be several pads overlapping each other. You would have to change that property for every one of them. If you switch to “Show the pads in outline mode” it might be easier to see all the pads there. Better yet go to the footprint editor and see what is going on there. It seems pretty weird to me that your thermal relief on the ground pad is not spaced properly.

I am also working both on footprint editor and directly on PCB as you said.

My footprint was converted from Gerber (it is the F Antenna designed by Texas Instruments version SWRU120C) to .kicad_pcb then to .kicad_mod. The whole antenna body is a polygon. This main polygon is surrounded by small polygons like tracks and I would like to use it as it is because I do not trust me to change this thing mutch.

This is the main polygon

These are the small polygons that make edges smooth

These are the PADS, both set “Solid” for “Pad connection”. The small circular PAD was previously set to “From parent footprint” but changed to “Solid”. Nothing has changed in the PCB.

This shows a polygon that connects the circular PAD to the rest of the footprint.

As you can see @ArtG, I have only 2 PADs and both have solid connections to the copper pour.

I appreciate any suggestions including any workarounds to make this thing fill the copper pour automatically but I would like to keep the layout as it is.

This is really weird. I was not aware that footprint editor can deal with polygons on copper layers. Looks like a hack and a recipe for a headache later. What I would do is to recreate the footprint by hand using only pads and have them all be numbered the same as the pin number for your antenna in the schematic. You can just recreate the design on top of the existing antenna, to make sure it matches perfectly and then delete all that polygon mess. You should be able to get the dimensions pretty close by doing that. You can recreate the whole thing with 9 pads and then just use a trace for the feed line.

1 Like

Ok, I will do that and I will update here when I finish.

Even better, just start a new footprint from scratch and build using the dimensions from TI data sheet

Sure! I did that way because I thought it was hard to keep the corners exactly the same.

@ArtG, your suggestion did work really nice. Thank you for the hard work helping me with this. Look, my draft antenna works very well but it would be really nice if it I could work in real life also haha.

Not sure what that a picture of, but it certainly NOT a picture of the antenna previously discussed. You need to split your antenna into discrete pads kind of like that:

I would probably make them overlap each other while keeping the same overall dimensions, just to make sure it is one continuous copper. Take the exact dimensions from the TI datasheet. You would need to convert them to the pad sizes and locations (preferably with help of a calculator). Good luck!

Sure, that picture was me validating your idea. Just removed all polygons and replaced them by a path with a few connected PADs. Now I am drawing the pads over the layout as you said before. I did that because to make them fits perfectly cost more time.

Sure! All PADs are overlapping to avoid empty spaces.

So, I am here to describe the whole process.

On schematic, I used an antenna symbol with a single connection. But I think we can use a symbol with 2 connections but shorting them to GND.

Then I created my antenna footprint. It was composed only by multiples PADs, nothing more (this is important). All PADs have “solid” for the Pad connection:.

Then, on layout, I added a keep out area on my 1rst PAD of my antenna to avoid the copper pour there.

This is the result after filling the areas with copper pour


I have found that this issue occurs because the polygon creates a short between the two nets.
A pad and a polygon does however only gets “connected” if the polygon overlaps with the center of the pad, so the workaround is to make sure that the antenna polygon does not overlap with center of the associated pads.
I have created a quick and dirty PIFA style antenna (demo only - not tuned in any way!!!) as a proof-of-concept using KiCad version 5.1.3 but I believe it should work in most other versions too.
PCB_antenna_PIFA_DEMO.kicad_mod (4.8 KB)