PCB not showing in 3D viewer

I have made a new installation of V8.0.2 on a Win 10 machine and on that machine the PCB is not visible in the 3D viewer. Even if I load a demo project, then open the PCB and then the 3D Viewer all I see is the components floating in mid air with no board!
On my other machine (Win 11 on that one), I did the same thing, installed the same version and opened the same demo and on there it works fine.
I have attached a screenshot of how the ecc83 demo looks on the Win10 machine (I don’t think this has anything to do with it being Win10 btw).

The same thing happens in the footprint editor.
Normally you see a board under the component when you edit the 3D model in the footprint properties, but on this new install the component is just floating in mid air with no board, making impossible to align because the component pads are not there to align to.

Can you zoom out a long way just to make sure your board isn’t floating around out there, I can’t create this without turning stuff off. :grinning:
:mouse:

@mousey points out the zoomed-in thing, which I have noticed in the footprint editor when importing and aligning a 3d model from a manufacturer, grabcad… They sometimes are just off screen and need offsets and such.

On the main board you may need to ensure that the board-perimiter line on the edge-cuts layer is closed. Also, parts outside the board edge will float (as expected):

This is as far out as it will zoom.


All I do is:

  1. Start the app
  2. “File” => “Open Demo Project”
  3. Open the PCB and then the 3D viewer.

I have also tried uninstalling and installing V7 and it’s the same.
So it seems to be something about this machine that it doesn’t like.
I tried the same things on a different machine and there it works fine.

The machine it is not working on is an Intel i9 8 core MacBook Pro running Windows 10 natively via dual-boot (boot camp).

I get this, also Win10 KiCad 8.0.2 rc2

Check that you don’t have anything weird in your board stackup . . .

Looks like this for me, I don’t see anything obvious there:


It’s showing as read-only because it’s a demo from the ‘Program Files’ folder, but I get this same symptom whatever I open, even if I create a new footprint, it also has no PCB in the 3D viewer.
It’s like there’s some "Don’t show me no PCB’ checkbox somewhere! :wink:

do you have a well formed (closed shape) on the edge.cuts?

Its a read only Demo project . . . :wink:

What about graphics, have you tried Fallback instead of Accelerated?

Thanks for the hint. I tried “Fallback” but unfortunately it made no difference.
I found that ticking “Raytracing” helps. It’s slow but at least the PCB is then visible.


On my other machine it works with this ticked or unticked with unticked much faster.
So is this maybe a graphics card/driver issue?

I think it usually is.

In general . . . graphics card/driver issues are helped when switching to Fallback, it’s not really a solution but it confirms where the issue may be.

It’s worth looking for a more recent graphics card driver from your PC vendor for you specific model of PC. Or if it’s a self build from the graphics card vendor directly.

Hi, thanks, it’s a MacBook Pro i9-8 core. The graphics are AMD Radeon Pro 5500M.
image
I’ll see if I can find a newer driver.

Strange because “Fallback” has no effect. Also, this raytracing option disables itself when you close the viewer and I have not found a way to enable that option in the footprint editor, so I still have the issue there with no PCB. So, still struggling really :slight_smile:

This may help: AMD Radeon Pro 5500M (Apple Bootcamp Drivers) - AMD Community

1 Like

Thanks for the hint. I’ll give them a try.

1 Like

Just a quick update to say that the latest driver from there cured the problem.
Many thanks for that!

3 Likes