PCB Editor is a blank window KiCad 7.0.8

I’m having an issue with Kicad where the PCB editor won’t open, it appears to open and I can view it in the task bar - which shows it as a blank white window - but if I try to bring it to focus it nothing happens. I’ve tried opening the editor from the project manager as well as from the schematic. At first I had some warnings when updating the pcb from schematic but they are all fixed now. I’ve also tried old files that were working and the same thing happens. I updated Kicad about 2 days ago with no change.
There is a .lck file that appears when I open it, deleting that doesn’t seem to have any effect.

I have used some custom libraries and made one or two myself, I don’t know if that could have any effect. I tried turning them off in library manager and it didn’t seem to make a difference.
I am using using Windows 11. Here is the Kicad info.

Thanks for any help :slight_smile:

Application: KiCad x64 on x64

Version: 7.0.8, release build

wxWidgets 3.2.2
FreeType 2.12.1
HarfBuzz 6.0.0
FontConfig 2.14.1
libcurl/7.88.1-DEV Schannel zlib/1.2.13

Platform: Windows 11 (build 22621), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Sep 29 2023 18:44:47
wxWidgets: 3.2.2 (wchar_t,wx containers)
Boost: 1.81.0
OCC: 7.7.1
Curl: 7.88.1-DEV
ngspice: 41
Compiler: Visual C++ 1936 without C++ ABI

Build settings:

What happens if you start a new project in KiCad’s project manager?

You can also try renaming KiCad’s configuration directory. If you do that, KiCad assumes it is a fresh install and creates a new configuration directory with factory defaults. There is no guarantee it will work, but at least you can exclude it has anything to do with your project or it’s settings.

Also: Edit the title of your post. KiCad version numbers have three numbers separated by two dots. Version 7.08 does not exist. (A surprising number of people make this mistake).

1 Like

This sounds very similar to PCB Editor does not open due to bad settings file (#15942) · Issues · KiCad / KiCad Source Code / kicad · GitLab.
Deleting the “pcbnew.json” settings file (in %APPDATA%\kicad\7.0) was helpful for the OP, the issue itself is still open.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.