Path to 3D files problem

One of my computers seems to have a wrong path setting. I don’t know where to fix this precisely as there are more than 1 place where you can adjust paths and all.

See the footprint propery box

The top line is default to this SOIC. It still has Kicad6 in the name when I am at 7.
The bottom line is what I found in the default library, this one is correct.

I tried preferences → configure paths


I went in footprint editor to ‘manage footprint libaries’. But I could see no anomalies.

Where do I change what into what?

Regards :coffee:


The versioned path leftover suggests that this project was originally created with KiCad v6. Depending on the OS, KiCad replaces or adds additional libraries for the new version, but either way there is no automatic editing of existing project files. If you were relying on an older footprint/3D model from the KiCad library, you wouldn’t want it to get updated secretly without you knowing when you update from libraries.

If you are okay with updating 3D models, you can just add another path in the Configure Paths menu for KICAD6_3D_MODEL_DIR with the same explicit path as the KICAD7 path. Alternatively, you can do the same change you did above to each footprint (or change each type of footprint to use the new library version).

They symbols were recycles from an other project due to some labels and vendor codes. The problem however are the footprints.

I managed to find me a decent fix and it was a simple one. I simply picked another footprint… It turns out that the SOIC-16 with almost the exact same dimensions does have a 3D model, where the (obsolete?) SO-16 and SOP-16 don’t.

It seems to me that whoever handles the kicad libraries may have forgotten this, or is too busy or whatever valid reason he or she has (not making accusations here). I am gratefull for what we have :wink:


Ah, I totally missed the SOIC- to SO- difference in your original post, apologies for confusing things!

Unfortunately, as you’ve discovered, not every footprint has a 3D model. It isn’t (often) a matter of forgetting, just a matter of who is motivated to do it for a given series of parts. That being said, all footprints have a 3D model name pre-assigned so that the 3D model can be generated in the future and dropped into the right place without changing the footprint.

1 Like

I had the same problem and grew tired of it - my post/solution…

Ah. I feared some links once worked and did not survive some updates, but I understand the paths were ment for future additions. That makes sense.