Path configuration

As I installed 5.1, I have a few things to tune. For example, the paths configuration has vanished. I was using a download of kicad-footprints-master, kicad-packages-3D-master and kicad-symbols-master. When opening the path setting menus, I have this:
I understand that KICAD_SYMBOL_DIR corresponds to the directory where I have unzipped kicad-symbols-master. I also suppose that KISYS3DMOD may correspond to 3D symbols, which should point to the directory where I have unzipped kicad_packages_3D-master (by the way, is this right)?
Now what about a variable for the footprints? Ther is no footprint variable.
Thanks for any hint!

Full detailed explanation Library management in KiCad version 5

The only variable you really need is KISYS3DMOD. (Assuming you want to use the 3d viewer.)
All other variables are there to make library tables portable. (To use the default library table you would also need to correctly set KISYSMOD and KICAD_SYMBOL_DIR. If you plan to use templates then KICAD_TEMPLATE_DIR might also be a good thing to set. The alternative would be to add the libs manually using the library manager instead of using the default library table with its path variables.)

Hello Rene!
OK, let’s be more accurate.
I have downloaded kicad-symbols-master and kicad-footprints-master. I have expanded them to. let’s say C:/Users/pascal/Develop/KicadLibs
I tried to set the KISYS3DMOD path to C:/Users/pascal/Develop/KicadLibs, then to C:/Users/pascal/Develop/KicadLibs/kicad_packages_3D-master, then again to C:/Users/pascal/Develop/KicadLibs/kicad-symbols-master, etc. nothing works.
Since I updated to 5.1, I have no more libraries.
Now I have just noticed that with “manage symbol libraries”, I can add them all at once by browsing to the proper folder, select them all and add. But this brings the next question: what are the paths used for, then? The paths didn’t change anything, I had no libs. Now with the lib manger, I can add whatever I want, so I don’t need the paths, apparently? Could you explain these paths?

They are only used if something tells kicad to used them. Meaning if the library table (the thing managed via the library manager) makes use of them.
Do not see these path variables as anything similar to search paths. They are simply variables and kicad simply replaces the variable name with the content of the variable. (It is similar to the processor instruction #define of the c language.)

Everytime any kicad asset has something of the syntax ${VARNAME} in it the full string is replaced by the value of that variable. So if you have ${KISYSMOD} in the path of a library inside the footprint library table this string is replaced with whatever you set KISYSMOD in the path dialog.

Example lets assume KISYSMOD is set to /home/mylibs and you have an entry ${KISYSMOD}/mylib.pretty then kicad will resolve this as /home/mylibs/mylib.pretty

Hello Rene!
Thanks for the explanations. And Eelik’s document will be indeed useful.

I am trying to read the above document and also this one

and I have a few questions.
At present I don’t see Kicad default libs, only mine. What should I setup to see the default libs when choosing the add symbol tool? I mean, not entering the libraries one by one, but as a folder. That’s why I thought the paths could make it.
Beside this, the link above speaks abot KICAD_CONFIG_HOME, which is not in the paths actually stored in Kicad (or maybe at another place, or maybe also hardcoded). And I don’t see KICAD_WKSFILE either.


I explain in my tutorial that you can add multiple libs with the library managers by selecting them using shift plus left click. ( In the file browser like tool that opens when adding libs using the button that looks like the open symbol. In v5.0 this was the browse button.)

I also explain further opinions in the reset to default section.

The above kind of assumes you already have the library files installed somewhere (It gives an option to do this manually in the advanced setup section) But if you want to use the system libs but they are not there then this might be a good read: I installed KiCad 5 (under Linux) but there are no libraries. (The default option for sym lib table setup is disabled) (For windows simply install a second time and this time select the installation of libraries)

Hello Rene!
OK, I reinstalled and it works! Thanks a lot.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.