Paste clearance = 0 on individual components


#1

Hi,

How can I set a Paste clearance to zero for individual components on the PCB?

I have different components on my PCB and for most of them I do want to apply some paste clearance (assume -0.04mm), so I use this value as a global paste clearance. But for some of them I need to leave 0mm clearance, but KiCad always takes 0 value as default and still applies global rules to them.


#2

Use 0.001 ?

It’s not elegant, but should be small enough.


#3

In kicad 4 there is no way to do this other then setting it to a small (absolute) value. The smallest value possible is 1e-6 (=0.000001)


There was a discussion on the mailing list recently about something similar.
It was decided that in future (kicad 5) will not apply global values to pads without any copper layer. (See blog post for more details)

So in kicad 5 it will be possible to have pads with 0 clearance as long as you put the paste layer on a separate pad without copper


#4

And, as madworm suggested, you can always just use a really small value. At least +/-0.000001mm is accepted by nightly builds and it’s so small there’s no practical difference compared to 0 after the manufacturing stage. It’s ugly but it works.


#5

Ok, thanks to everyone for the info!
Once again KiCad community is extremely fast and helpful
Cheers :slight_smile: