Passes over a track on the same network without joining it

HI, Because KiCad do that?, passes over a track on the same network without joining it.image capture. Thanks

pcbnew 4.0.2+e4-6225~38~ubuntu14.04.1-stable

You question is not clear, but if it why on your screenshot the GND is not connected, that may be expected, depending on your settings for your zone that you set. If it is not connected it is because your settings on the zone do not allow that it can be connected.
It is in general a normal situation, if it is what you desire. Even that way, if you need that connected, you need to trace manually a track. KiCad is doing that because it is following the rules that you set on the zone parameters.


@kammutierspule is right, I believe that the setting you need to lower either of these settings of the zone fill:

  • Clearance (mm)
  • Minimum width (mm)

They must be too high for KiCad to be able to bridge the GND pad. Don’t forget to recompute the zone fills with the ‘B’ shortcut.

1 Like