Parts Chooser So slow to load, can it stay open?

I am not sure if its my settings or what, but every time I go to place a part in my schematic the parts loader takes about 5 to 6 seconds to load. Once it loads the filtering is zippy. but then i chose a part and lay it down, then i click again and its another 6 seconds to load. And yes I am loading all my libraries I have tried it even with just a few libraries and it is still slow… Would be nice if i could just keep it open. But do you guys have any suggestions how to mitigate the problem? I have a beefy desktop with 32gb of ram and 6 cores, I have monitored the ram usage and cpu usage when I open up the parts selector and its not putting any significant load on ram or cpu so i have no idea what the issue is…?

KiCad version, operating system?

Definitely something is wrong, because I’ve found KiCad to be quite responsive on an ancient dual-core system with 3 gigs of RAM.

Usually when this happens, you are running a Windows system and have some form of network drive mapping. Not always, but that would be my first guess. To test, you can turn off dropbox/google drive/ windows network shares. If that’s not it, then I’d test with the AV disabled. If that fixes it, then you will want to add some rules to the AV ignoring the proper files.

Let us know if you are still having issues after trying this. Also, be sure to post your KiCad version information (Help -> About KiCad -> Copy Version information)

–edit– See @Sprig below. This is also a good thought. Posting an image of your symbol library tables could also help track down the issue.


Kinda sounds like github library fetching.

1 Like

@Spring could be right if you had v4 installed in the past then kicad might still try to lookup footprint information from github. This should however only come into play if you also have the experimental part chooser dialog enabled (The one that allows selecting footprints at the same time as selecting symbols)

Just in case you have the old lib setup still surviving: I had KiCad 4 installed previosly. Now i updated to v5. Now i have some problems with the library setup

To turn off the experimental part chooser: preferences -> general -> display -> Footprint previews in symbol chooser (experimental)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.