Pan while moving items on schematic too zippy?

In the older versions before 5.1.9, when grabbing part of the schematic to move it to a new spot, in previous versions, the panning feature moves at an appropriate speed, making it easy to get things lined up.

When doing so in 5.1.9, it seems like the screen starts zipping by like Usain Bolt after having downed several shots of espresso. Is there a setting I need to change?

Are you using the pan function that activates when pushing against the side of the Eeschema drawing area?

Simplest solution is to get used to it, just pump briefly into the side instead of a long push.
Pan speed in V5.1.9 seems usable to me, but because I personally do not use that function I do not know of scroll speed changes. Instead I make a selection, and then while dragging use the scroll wheel to zoom out and then in again on the area of interest. This way you have both a better overview and more control over locations.

This works especially nice with the default setting of Preferences / Preferences / Common / Pan and Zoom / [x] Center and warp cursor on zoom. Some people turn this feature off quickly after starting to use KiCad, which is quite a shame, because if you’ve given yourself a bit of time to get used to it, you would not want to live without it.

Yes, this is the pan feature that kicks in when dragging towards the edge of the visible screen area.

The difference is like stomping on the gas at a green light versus easing into the throttle like it used to. The acceleration ramps up TOO fast.

I already have the setting you described enabled…

I wound up rolling back to 5.1.6 for now.

There have been quite many changes between 5.1.8 and 5.1.9 and a new bug may have been introduced. Please report a bug and insert exact information about your system. Even the screen type may be relevant (high density vs. normal).

Does this happen in other views, especially pcbnew?

Can you take a screencast with a good version and 5.1.9?