Pads show on silk screen when printed

Hello all,

In the older versions of Kicad (BZR4022) the front silk screen could be printed without the component pads being shown as a copy of those on the front foil layer.

In Plot mode (Gerber) there is the option to turn off pads on silk layers, but not in print mode.

For some reason the top silk shows filled shapes which correspond to the component pads when printed (see *.pdf) but not on Gerber plots. See GTO + GTB files.

Unlike the BZR 4022 version where the pads were a muted yellow, the 4.0.4 ( & 4.0.2) versions pads are bright yellow.

Frequently I make prototype boards and have to print a paper copy of the silk screen, and this sometimes means that other data is illegible.

Is there any way to turn these off in print mode?

ThanksAGC_Preamp-F.SilkS.gto (90.0 KB)

Print Fsilk_Bsilk.pdf (40.1 KB)

AGC_Preamp-B.SilkS.gbo (12.5 KB)

If I look a project using KiCad current and select Print, I have the option to disable F.Cu and then the pads vanish

Hi davidrsb.
Thanks for your reply.
Mine is a double sided board. I have only F.Silks checked and I get filled pads on the top screen when printed.
If I check “Exclude PCB edges” I get non filled outlines of the pads. Neither of these really want on the front silk.
It looks like some kind of print bug to me as the Gerber plots are fine. Maybe it is only a Windows thing (win7 64bit version) as I have not seen it mentioned anywhere else.
Why it should appear on other layers I cannot say.
Pads are normally on all copper layers unless specifically changed for multilayer PCBs, but not usually on fab and info layers.
Why would the exclude PCB edges tab affect the filling or not of the pads?

Do I understand you correctly, you want:

  • print outline
  • print silkscreen
  • nothing else

I just tried with KiCAD 2016-09-17 rev 679eef1 on Windows7 64bit and these settings:

Result only shows the Back silkscreen in a outline of the pcb… as expected.

silk+oline.pdf (28.6 KB)

Now I tried the Front silkscreen alone and it works as well.

But, for this to work, those layers needed to be switched visible in the PCBnew canvas… see the layer visibility switches to the right of your canvas:

Without them active they won’t show up on the print either.

I found that “feature” confusing too

Printing is definitely a bit messed up. I assume the op is referring to through-hole pads and yes, when printing I also get the through-hole pads even if the only layer selected is the F.SilkS, regardless of the other settings. Selecting “Real drill” will put a hole in the pads but the outlines are still present. To make matters more confusing, with “1 page per Layer” selected I get solid pads but if I select “Single page” I only get the outlines of pads.

To fix this go to the “Render” tab and deselect “Pads Front” and “Pads Back”. Or just print from GerbView.