Pads hidden by silk screen when pulled from V4 design

Not sure if this is a bug or something I am missing.
When I open a PCB file created in V4.X.X in V 5.1.0 (and in V5.0.1) then some pads are covered by the silk screen. If I edit the pad, it is shown as silk screen being checked in pad properties. It appears that most (but not all) of my old V4 library items suffer from this. It would not be a problem except that the Gerber prints are also showing the screen print over the pads. Unchecking the silkscreen box clears the problem.

Is there a global method to change the pad layers or do I have to wade through my entire library to change them?

There’s Exclude pads from silkscreen option in the gerber plotting dialog. I remember that there was some discussion about this, @Rene_Poschl knows more.

Well if your personal lib has silk on top of pads then nobody else then you is to blame. The official lib did not allow this for a very long time. (And yes i am aware that v4 had this by default. Reading the library convention might always be a good idea even if you plan on making the asset only for yourself.)


Well if your personal lib has silk on top of pads then nobody else then you is to blame.

It may well be but, can you tell me why please?

@eelik Thanks for that. I remember now!

There was a short spell with one version of V4 where pads were printed to the F silk but were fine when plotted to Gerber.
Mostly my problem seems to be with items copied from the V4 or ever earlier mod libs which were then assigned to a specific device, so that a PIC12F629 was linked to a DIP8 footprint and saved as a P12F629 in my library as a footprint.

There is one 32 pin connector that I know I made from scratch and it was fine in V4.0.7 but in V5 the Fsilk covers the pads. The pads were just pulled from the pad assign tab in V4.0.7 PCBnew footprint editor.
The only change made was to edit the shape to be oval. Everything else was left at default. and then each pad copied.

The pads that show as covered all carry the Fsilk tab checked, but no pads do in V5 footprints items. Is this something that does not carry over from V4 correctly or was the default to have front silk checked in V4 that causes the issue?

As I never had any problems with it, I never checked this out.

I was just hoping that there would be a way to edit the pad settings globally to remove the silk from the pad.

You can use the “subtract mask from silk” option for generating gerbers. (As suggested above)

But you might want to go through your lib and fix the pads that have this selected

I am not aware of a way to globally change footprints other than a text editor. Or possibly use our official test scripts with the --fix or --fixmore options. But be aware that these scripts are meant to get footprints as close as possible to fully KLC complaint (Might be a lot of stuff that gets changed if you did not care to make footprints complaint)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.