Pads automaticaly associated with no net (Solved)


#1

In the screenshot I have 3 sets of pads. When it comes to pad 1 of P1,P2,P3 they are linked together with no net.

With the netlist update I have tried with Delete single pad nets as the screenshot is the result. If I use ‘Keep’ they are no longer associated nor can I join them with tracks but the correct association still does not happen.

Am I missing something.

Windows version 4.0.5


#2

If you click on a “no connect” pad, KiCad highlights other no-connect pads, but there is no net linking them.

However, it looks like a problem with your schematic, there are genuinely unconnected pins.This can happen if pins are slightly off grid etc. It’s hard to tell from the screenshot.


#3

They’re all connected as also the ‘Perform electrical rules check’ gives no errors. Which is set to defaults. It’s not just ‘no connect’ but also highlighting to ground.


#4

Perhaps the netlist needs updating, does it show the correct connections?


#5

I’ve updated the netlist several times, schematic and Pcbnew, with different settings. Two different results as on the original post but no luck. All the other pads are fine except for P1 for all 3 sets.


#6

Can you show us the symbol you used for the connectors? Maybe the problem is hidden inside these symbols.


#7

I actually found it as you posted. Looks like a pin was hidden within the pad, only noticed on moving it. Since they where created from the same template it was in all of them. Pad 1 was the problem, yet Pad 2 had the hidden pin. Electrical rules checker should have picked it up.

Quick question, How do I mark a post as solved.


#8

Simply edit the title. add (solved) to it.


#9

Thanks, I thought there may have been a button somewhere.