Pads and their 3D models are inconsistent

I would like to know if this was intended in anyway. The pads are not aligned at all with the 3D models for all the CP_RADIAL through-hole capacitors.

Yes, the 3D models and footprint libraries have got out of synch. Search the forum for answers.

Aha so I wasn’t hallucinating then!

I did a quick search but didn’t find the answer. For now, I’ll edit it manually…


Hi you need to update the footprints and 3D models
see here; Incorrect component models in 3D viewer?

@Joan_Sparky do we have an FAQ somewhere?

1 Like

Not that I know, @Rene_Poschl posts a copy&paste piece from time to time about how to get this sorted out I think?

Thats what I linked to, this seems to be a common issue, hopefully it will get better in V5 with a proper git plugin.
could we perhaps make a tutorial and make it a sticky thread?

I pinned the topic you linked to globally until Sept 30th. Should suffice, or?

Fixed the topic spelling and changed category to 3D

1 Like

So it was simply updating the modules. Thanks Shack.

1 Like

I fear kicad 4.0.7 might not get new libs. (Which would mean this problem will persist. At least until 4.0.8)

I think it is the wrong decision because the footprints are updated everytime kicad needs them. All because the github plugin is the default setting. (I did notice this too late.)

1 Like

I have a question about this issue.
So, if we’re using the stable version and the online library; the footprint library will be updated every time we access it (seeing as it is a live online library), but the symbol and 3D model libraries aren’t updated unless we update them manually?
That is very confusing to me, doe that mean the the symbol and 3D model libraries are downloaded as local libraries by default?
I’m certainly not complaining here, so far I think KiCAD is freaking awesome!!!
I’m just trying to wrap my head around this. I thought by continuing to use the online library we were assuring that everything was as up to date as possible automatically. But, this doesn’t seem to be so?
BTW - I am in no way any kind of coder or programmer, so go ahead and explain it like I’m a moron! LOL

There is nothing planned in v5, v6 would be the next opportunity, I guess that will be after 2020.

Really though, the way to solve this type of issue would be to have all the data (symbol, footprint, 3d model) in one file. For as long as there is a file path embedded in a file, the possibility of getting out of synch is likely. I guess an alternative is to have fine grain versioning of objects, but that is also a whole lot of work. A simpler option more in line with current KiCad might be to have 3d library tables, and use a “lib_name:model_name” identifier. Oooh, and then add versions “libname:object:version”, that could also apply to footprints and symbols :slight_smile:

Well, designing on paper is easy, in the meantime, we’ll have to rely on everyone understanding the library workflow. :slight_smile:

1 Like

Yes sadly there is an inconsistency in the library system. Currently only footprints use the golden github plugin. This plugin downloads your footprint libs to a temporary location everytime it needs them as a zip dump. (It uses the github api for downloading a repo in zip format.)

For symbol and 3d model libraries there does not exist somenthing similar. Currently they are included in the installation of kicad. (For linux it is a separate package for windows you can tick a box to install libraries)
The only way to update them is by downloading the repo your self and getting kicad to use your downloaded files. (By setting KISYS3DMOD for the 3d files and by changing the system template to add your symbol directory to the searchpath.)

My suggestion is you setup local footprint libs plus your own copy of the kicad library repo and update when you want. This way you have control over it. (This is a workaround for now. Hopefully v5 will have better options. At least the 3d shapes downloader that currently exists in the nightly builds should also be added.)

Thank you for that explanation, it even makes sense to me.
Perhaps I’ll plug along as is until I have an issue.
But, now I’ll know why I’m having an issue when it happens.
Hopefully plugins for the other libraries are a possibility in future versions.
In the mean time, thank goodness for this forum!

Umm seems everything is still the same :confused: I followed @bobc tutorial. Here is what I exactly did:
1- Opened the Footprint Libraries manager and manually deleted all libs.
2- Append with Wizard →Github repo (the text field was already pointing to the repo)
3- The save to a local copy was marked in red as it wasn’t possible to write in the directory (I am on Linux), so I had to run KiCad first with root privileges and redo the steps.
4- Next → Select all →Next → Done

What is wrong ? Here are the current parameters:
$KISYS3DMOD: /usr/share/kicad/modules/packages3d
$KISYSMOD: /usr/share/kicad/modules

for both folders and recursively, the superuser is the owner and anyone can view the content.

EDIT: I chose the installation directory to be /usr/share/kicad/modules when inslalling

Setting up the local footprint libs only prevents future problems.
(His tutorial downloads the footprints that are in the repos at the time you download them.)

You still need to download the 3d libs and point KISYS3DMOD to your freshly downloaded 3d files location.
I would suggest you clone either the kicad-library repo (This will be the legacy repo once v5 comes out.) or the packages3d repo (fewer models because only models that include step files are included) into your user folder and let KISYS3DMOD point there.
(Otherwise you need root rights to overwrite the content of /usr/share/kicad/modules/packages3d)

Create a KiCad directory in your home directory and a sub directory modules.
Change your library location away from root owned usr.
There is no need to sudo KiCad and it is a bad idea

1 Like

Thanks for the reminder. Yes it’s a bad idea and it has unforeseen consequences.
Regarding updating libraries, I took a bruteforce approach but it didn’t work firsthand. I then followed @Rene_Poschl advice and cloned the kicad-library repo into a local folder (Rene, your first link is the same as the 2nd). Then, since there were no modules by default, I launched the manager again and it works now :slight_smile:

Still, with the update, there are some components having the same issues, namely the CP_Axial group of capacitors. Am I right ?

1 Like

thanks, fixed

Should not be the case. Could you give us the exact footprint (or one of them) that has a problem?

Do you see it when you open the footprint via the footprint editor and open the 3d viewer from there?
Remember you need to update footprints that are already part of a pcb.

The CP axial was updated today, I believe they were only merged on the new repo, possibly because @SchrodingersGat wants to freeze the old repo.

I would suggest to clone the new repo

1 Like