"Pad to close to Pad" DRC with Wurth pillars

I am presently using some Wurth PCB pillars and the footprint is part of the main library
Mounting_Wuerth_WA-SMSI-M3_H12mm_9774120360

I have been going through my placement correcting all the DRC’s before getting into detailed work to minimise rework later on.
I have 7 DRC left and all come down to the same footprint

Looking at the footprint, it is as per the datasheet but DRC is failing. It would appear to be due to the fact the part has copper to the drill hole rather than a gap.

Is there anyway to turn off this DRC in 5.1.6 ( I believe the ability to ignore DRC exist for v6)

I loaded the same footprint from the default library with the same result.

Then I disassembled the footprint in the Footprint Editor:

The Footprint is more complicated then I’d expect.
I can not help much here.
Pads without pad numbers are handled in some special way in KiCad, but I do not know much about that detail. Maybe there is something about the manual about this, or else wait for others to respond.

This is a known issue with the non plated options. Just ignore the DRC error we did not really come up with any option that would not trigger something.

1 Like

Thanks, just wanted to check.