Pad-Specific Thermal Relief in Plane


#1

Hi,

I’m designing a high-current board with a single ground-plane, and I’m trying to remove the thermal reliefs on the high current pins only. The rest of the pins should have thermal reliefs for ease of assembly. I tried creating two seperate pours with the same net connection, but the high-current pour only covered the high-current pins, and had a solid thermal relief setting, but when I ran a DRC the bigger signal ground plane swallowed the smaller power ground and overrode the thermal relief settings.

Any help is appreciated,
Thanks


#2

DRC is best called Design Regenerate and Rule Check (DRRC), and it can use its own ordering schemes for the regenerate of thermals.
You sound on the right track, but may need to avoid the overlay of planes, - ie make the smaller one ‘outside’ the larger one, by using a re-entrant path.

You could also try a Zone priority level change ?

I see there is thermal settings by PAD, but they chose 0 as ‘use global’, when maybe -1 might have been better, in order to allow someone to actually ask for 0 thermal clearance (ie flood-over)

No wait… I just tried a -0.1mm clearance, and it seems to work :slight_smile:
ie 0 might be reserved for use global, but negative numbers seem valid.


#3

Thanks for the advice. I found another workaround that does the same thing basically… Essentially I put track that was slightly larger than the thermal relief clearance over the pads I wanted to have solid connections. The tracks automatically override the plane, and I get to keep clearance on non-power pads. I’ll try the negative clearance though, that sounds like a much more elegant solution.

edit: I can also force the connection by editing the pad in the footprint editor it seems.

edit2: It also seems that I can force the same thing in pcbnew, but only on some footprints, and not others?


#4

In the footprint if you select the pad to edit there is a second tab which has per-pad settings. The default is to inherit the properties of the zone, but you can specify no connection, thermal, or solid.


#5

cbernardo has the correct solution here. just hover over the pad in question, hit the ‘e’ key, select the ‘local clearances and settings’ and set that particular pad to solid. No more thermal! And no playing with fills inside fills, or negative clearances.