Pad properties (net name)


#1

Hello

i have a problem about a footprint.

I have drawn two footprints but,when i want to use the mouse to watch and modify the pad properties,i have a problem.

The first fooprint leave me to access and modify the net name without any problem but,the second footprint,doesn’ t leave to make me this operation.

This happen when i am drawing a pcb and want to modify the net name.

What is the problem?


#2

I assume you want to change the pad properties (net name) of the footprint you placed on a pcb (within pcb_new)

If so: What dialog opens when you press e while hovering above the pad in question? (post a screenshot if you are not sure)
What happens if you try to leftclick on the pad (does a dialog open where it asks you what you want to select? If so: Is the pad in the list?)

It might be possible that your footprint is locked. Open the footprint properties dialog (press e while above the footprint. Or select the footprint first by leftklicking and than press e.)
Make sure the move and place options are not set to lock footprint.


#3

Thank you for the answer.

Following your advice,i have watched that the footprint was locked.

I have adjusted it (as you have said me how to make)and now it is right.

Thank you again.


#4

Why would you do this?
Nets are being defined in EEschema. PCBnew afaik doesn’t allow you to change net names unless they already exist.


#5

Via stitching would be an example.
Or a mounting hole that should be connected to ground. (And for some reason the user does not want it to appear in the schematic) …


#6

There was a small error corcening the name written on the name.

The EEschema is exact but,in the net name,it showed wrong.

However,making in this mode (changing the error on the net name), i have solved the the problem.

Thanks.


#7

Why not simply correct it in EEschema, reexport the netlist and update the pcb this way. (If you only change it in pcb_new, your schematic and pcb might be inconsistent. This could lead to problems later on.)


#8

I had already tried to make as you say but the EEschema was exact.

The problem was only where i have said and,for this reason,i didn’ t understand what could have happened.