Pad not found when read netlist

I have error when reading netlist:
Module [U1]: Pad [2] not found
Module [U1]: Pad [3] not found
Module [U1]: Pad [5] not found
Module [U1]: Pad [6] not found
Module [U1]: Pad [7] not found
Module [U1]: Pad [8] not found
Module [U1]: Pad [9] not found
Module [U1]: Pad [4] not found
Module [U1]: Pad [1] not found
Strange that 1-12 pins all should be ANGD but 1-9 not work and 10-12 is ok.
Here is the pics of module - schematic symbol, footprint and how it looks in pcbnew after reading netlist.
All pads-pins names are correct. I dont know what the problem here.
Please help me.

You have symbol with pins numbered 1…9, 10…48, while footprint have pads numbered 01…09, 10…48. This is the reason. Remove leading zeros in pad numbers.


Thank you very much!! its help! for me works to add zeros at schematic symbol. I didnt realize that kicad is so sensitive

It must be, because of BGA housings…


I think pin numbers are case sensitive too, anyway assume that they are and try to be consistent.

i am getting this error what to do?

Back to Eeschema and start CvPcb.

1 Like

how can i add 7805 in cvpcb ?

Lets slow down.

7805 is a component that comes in many different packages. (TO-220, TO-263, …)
Each package needs a different footprint of course. Some of these packages can be placed in different orientations (Vertical, horizontal with the tap down, horizontal with the tap up, …)

So you need to first know what version of the 7805 you will be using. And you also need to know how you want to orient it.

There are different options on how to connect a symbol to a footprint.
Option 1 via a tool called cvpcb. Found in eeschema: Tools->assign footprints to components (Might be called differently in your version of kicad.)
This tool allows you to edit the footprint field of all your components in a tabular form.
If you want to assing a footprint to a component, select this component in the middle column and click on the desired footprint in the right column. What is shown in the right column is determined by the filter settings.

Option 2: via the footprint browser (edit symbol direclty.)
For this workflow simply hover your mouse above the symbol you want to assing a footprint and press e.
In the dialog that opens select the footprint field and either type in the correct footprint by hand or use the footprint browser to assign your footprint.

In the footprint browser you need to select the footprint lib in the leftmost column and the footprint in the middle column. (Single clicking updates the preview, double clicking assigns the footprint.)

There is also a third option.
You can setup your lib such that your symbols have their footprint pre assigned. This is called atomic part.

If you are unsure about the terminology of footprint and symbol maybe reed this post i wrote a few days ago: (Click on the link to read the full post.)