Pad clearance graphic goes on and off with silkscreen, am I missing something?

Bottom clad shown:

Bottom Silkscreen selected:

Bottom Silkscreen unselected:

No, you are not missing anything.

The pad clearance graphic is there to guide you with laying the tracks and moving footprints; consequently, it is only necessary on the layer you draw tracks or move pads/footprints.

Perhaps another reason it is omitted on other layers is because it is just not useful noise.

Thing is . . . it’s not omitted when the other layer is selected i.e. bottom silk, but only when that layer is also hidden.

Using the appearance manager, as @JohnRob does, hides the pad clearance graphics in all but the pad/track layer if there is nothing pending.

I used the Esc key before changing layers.

There are some minor GUI issues here in KiCad V7.0.10. (Also verified in V7.99) When all layers are turned on, switching between the top and copper bottom layer only shows the clearance for the active copper layer.

When you toggle the active layer between F.Silk and B.Silk, the clearance is shown only on the last selected copper layer. It does not change with Front / Back.

For any (non copper?) layer: (Tested with User.4, Courtyard and some others). When it is the the active layer you turn it off, clearance outlines on both copper layers are hidden, and when visibility of the active layer is turned on again, clearance outlines for both F. and B. copper is shown.

I had never noticed this before. Is it worth creating an issue for on gitlab?

I’ve been trying to think of a scenario where it might cause a functional issue rather than an annoyance but couldn’t think of anything. So while it may seem a little strange/weird I don’t think I would call it a bug.

Things that cause (small) annoyances which can easily be avoided are also bugs in my opinion. Often they are side effects and just overlooked. I have reported a bunch of such small things and they usually get fixed with a few hours or days.

In my situation I was trying to clear all (non connection) related screen items. To more easily get a vision of how to move my components to get a better layout. This issue does not let me do that (and keep the clearance info).

1 Like

Ah OK, just did some more testing and things are getting a bit stranger. Seems I have to re-select a copper layer to get the clearance back on.

So if I have a non-copper layer selected and then hide that layer the clearance goes off, selecting any other non-copper keeps the clearance off . . . only selecting a copper layer or selecting a turned off non copper layer and turning it back on brings the clearance back on.

Yes, that is the thing you could consider to be a bug.

KiCad has: PCB Editor / Preferences / Preferences / PCB Editor / Display Options which has a Clearance Outline section, so you can select how you want KiCad to behave here.

Preferences seems to change to clearances for tracks but not pads.

I can repeat the issue by (my test layout is 2 SMD resistors on the front copper):

  1. Turning off ALL layers
  2. Select a non F.Cu layer (but not still not visible)
  3. Turn on the F.Cu layer = no clearance lines around pads.

I think we should raise issues such as this, allowing the developers to deem it something to change or not.

So how would I log this issue with Github? Is there a link to the appropriate location?


KiCad development switched from using launchpad to gitLAB several years ago. I don’t know if they actively used gitHub, or whether that have always been forks or passive mirrors.

To create an issue on gitlab, you need a gitlab account. After that you can simply use KiCad / Help / Report Bug. This opens a web browser, goes to gitlab and fills in a template with your version info, and you can just fill in the rest of the template form.

Thanks, I have to rethink this peculiarity as, when I go back and actually try to do work on the F.Cu, when the F.Cu is selected the clearance comes back. Perhaps I jumped the gun when calling it an issue since as soon as I select the copper layer the clearance come back.

1 Like

Yes indeed. Often I put some extra effort into making a bug report to both keep the text short and explain the problem clearly. KiCad developer hours are limited, and if spending 20 minutes extra to make a good bug report which saves them 5 minutes in reading, interpreting and finding the bug I consider it a win.

Some of the simple things are also explicitly marked as beginner issues for people who want to start with bug fixing and development in Kicad.

1 Like

This seems to be a bug. I have been experimenting.
“Track and Via clearances” are set to Always and “Show pad clearance” is ticked. See @paulvdh above screen grab.
For typing brevity I have Fcu, Incu (Internal copper layers), Bcu, Rest (any and all non copper layers).

Switching Layers in Appearance manager:
2 layer board.
Select Fcu then Rest - pad clearance stays.
Select Bcu then rest - pad clearance stays.
Select Fcu then Bcu - pad clearance disappears from Fcu and remains missing if Rest is selected.
Select Bcu then Fcu - pad clearance disappears from Bcu and remains missing if Rest is selected.
Select Fcu then Rest then Bcu then Rest - pad clearance returns and stays on both when selecting Rest.

4 or 6 layer board.
Same as 2 layer except:
Select Fcu then Incu then Bcu then Incu then Rest - no pad clearance on either Fcu or Bcu.
Select Fcu then Rest then Bcu then Rest then Rest - pad clearances have returned.

7.0.10 and 8.0.0 RC1 both work exactly the same.

I can’t replicate this behaviour . . . are all your layers visible ?


I used one SMD footprint on top layer, one on bottom layer and added a couple of tracks.

I’m on Windows, maybe it’s a Linux thing ?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.