Package name in BOM and *.pos file - how to change it?

Hi All,

That is my first post here, so greetings from Norway to everyone!

I’ve met problem. When I export BOM list of my PCB, package name is followed with library reference:


I can remove “SMD_Packages” part with simple text search and replace, so here is not big deal but would be fine if I could have what I need without additional manual work.

Problem is pick&place (*.pos) file where package description contain only 16 characters.
So instead of SMD_Packages:SM0603 i got only SMD_Packages:SMD.

Here simple search and replace trick will not work.

So, my question is. How to force KiCad to export to BOM and pick&place file ONLY package name without library reference?

In ver 5309, when I generate a .POS file, the library name is not included. It outputs just the package name. Maybe you can try a more recent version of KiCad.



I’m using 5021 and since this one didn’t make me any troubles I didn’t bother to upgrade.
I’ll try right away something more fresh.

Thanks for tips.

hehehe :cry:
Again golden rule “If it ain’t broke, don’t fix it” worked out :frowning:

During compilation I got build errors (during PCBNEW build), so now I’m without working PCB module. :confused:
I did reported that bug on KiCad website.

You can try to install one of the Milan Horak’s prebuilt packages:

Thanks guys for help.

Problem solved.
I did clean build (not an upgrade). This worked out but took much longer time to compile than upgrade compilation.
Now I have 5319 version and pick&place file looks good.
BOM still has library reference upfront of package name but that I don’t consider as a problem since I can easily fix that with small find/replace work.

Thanks once more.

1 Like


Sorry to digg up such an old topic.

The 16 character limet isn’t working for me. I need a .pos file where the Value of my components includes several item like voltage and dielectricum specification like 100N-X7R_50V#0603. Now it is chopped of to 100N-X7R_50V#060 and my cad import for my PnP machine isn’t working anymore.

Does any one know how to change this limit or do i need to make it as a request to the Kicad society ?

i found a bug report