Oval pads with two holes : no ground connection when filling ground plane

I have a problem with a couple custom footprints I created (the example below is a well known buck converter module). Through hole pads are made of two pads : oval + circular. The symbol has pads #1 and #4 set to “power input”, and they are connected to ground in the eeschema.
When filling the ground planes, these pins are not automatically connected to ground.
Why ?

Of course, I can put thermal spokes by hand, and they will not be removed by the 'Cleanup Tracks and Vias" command. But if I change the thermal spoke width in the “Copper Zone Properties” dialog, I will then have to edit the custom spokes widths.

I tested “Pad connection : Thermal relief” in the pad Properties dialog. Gives me this (too much copper around one pad, no copper around the other) :


I tried assigning no number to one of the two pads. No success.

I also tested this : I swapped the pads definitions in the kicad_mod file, thinking of some problem with z-order (round first, then oval and vice-versa : who knows…). No success.

I’m out of ideas.

Is there a way to define custom spokes in the footprint editor ? Something like this :

Is there a limitation for such pads (I understand it’s a hack), or did I miss something ?

If you’re willing to Hack… This may work for you…

Oval Pad
THT Y-Offset
Copy&paste it, Rotate the pasted one…
Change one of the Pin numbers to ~
(or set desired pin number or, ‘invisible’ the one you don’t want)

[EDIT] Just for fun… you can make a Custpm Pad (Graphic Polygon) and trace around two Circles… Quickly/Crudely traced and I didn’t clean it up or set Pin numbers to same or/other… Image below…

(did not bother to hide extra ref or label…)

The Custom Pad version…


If I remeber correctly, ‘~’ is a thing with Eagle (says pins are internally connected in a part), but is a valid name/number pad in Kicad…

Or is it a new feature with Kicad 6.0 ?

Anyway, still no automatic connection to the ground plane :disappointed_relieved:

Just had a look at the JLCPCB drilling capabilities : 0.2mm. We get this : the result is just perfect, and it works perfectly with the zone filling tool ! 2 round pads, and a square one in between (same dimensions), with a 0.2mm hole.

Pad 1 : two square pads side by side, no third pad. Works perfect !


I think the problem is solved !

(probably reinventing the wheel)

[EDIT] I tested with a 0.0mm hole for the third pad. Kicad just says there will be no hole…


Setting a pad number for the third pad (middle), and none (empty field) for the others gives a much cleaner results.


1 Like


I’ve been searching about ‘~’ and it meaning in footprints. I found nothing. But I see it is frequently used in the standard libraries.

Searching one single character is not allowed by the search engine (for obvious reasons !).

All I found was some sort of macro for active low pins in symbol editor…

Could you briefly explain ?

It’s in the Manual for Eeschema.

Search in the Manual for ‘Tilde’ (it’s in Pin Creation…)

The question is about the footprint editor. ‘~’ is documented for eeschema and symbol editor.

No mention in Kicad 5.1 pcbnew reference manual.
pcbnew 6 footprint editor reference manual is tagged “TODO” (empty).
Some information with Google : seems it is equivalent to “hidden” or to an empty field. But it displays as ‘~’ in pcbnew.

I still don’t understand the point. Already spent a couple hours googling on this mysterious char, reason why I’m asking this question…

It is usefull in Eagle footprints, but I still don’t see about Kicad footprints.

Just a “name” for something that does not need one, but will still be visible ?

What KiCad version are you using?

I remember the drawing artifacts of the brighter spots in corners as something that is a few years old.

It is 6.0.2

Not sure I understand what you mean about artifacts. It seams legit : objects alpha channels addition.

Transparencies are ajusted so corners display this way, in order to detect tracks inside tracks and pads.

BTW, about Eagle, I just recall that it is “@n” suffix and not ‘~’ prefix that is used for multiple pins with internal connections.

Still don’t understand tilde in pcbnew… Feature or convention ?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.