Outline layer not plotting to Gerber


#1

Hey guys,

I’ve been trying to plot my PCB design, but whenever i try to plot the outline layer, the Gerber files comes out empty. I’ve tried various things, but nothing seems to work. The outline renders fine in PDF format…


#2

What line width did you specify when you defined the outlines? If it’s too narrow, it may not show on your monitor display. I think PDF has a floor value for line width, and any lines which are narrower than the floor value get widened to the minimum printable width.

Dale


#3

Hi Dale,

I’m not sure. However, i loaded the outline file into this viewer: http://mayhewlabs.com/3dpcb and it didn’t detect any outline at all.


#4

By Outline, do you mean board outline Edge.Cuts or component outline X.CrtYd or X.Fab.In the Plot dialog?
The Edge.Cuts layer is not always ticked by default


#5

In the “Plot” dialog there is an option to “Exclude EDGE layer from other layers”. This does, in fact, enable or disable an overlay of the Edge.Cuts layer on other layers - at least it does in the KiCAD versions I have used. I wouldn’t expect it to have any effect, either way, when plotting the Edge.Cuts layer itself, but have never investigated that possibility. You might try making plots of Edge.Cuts with that option selected, and unselected, and see what results you get.

Dale


#6

That viewer was a bit buggy last time I tried it a year ago… especially the outline didn’t get created and it only used an ‘emergency’ box that encompassed everything on the board (same you get in KiCAD 3D viewer if you have a non-closed outline defined).

You might want to check out other options for controlling gerbers that are more reliable…


#7

I’ll keep trying. When i uploaded the design to Dirty PCBs, it didn’t show me a render of it either… Hopefully by the end of the day I’ll get it figured out.


#8

Ok, sorted - when i tried it at college, it worked perfectly. Wierd. I’ll reinstall KiCAD when i get home, see if that helps… Thanks for all the help though folks!