Origin, Gerber Odd Results

This may be unique to my situation in that I import the Gerbers into CopperCam (for milling my PCB’s).

Hopefully I can get pointed in a direction to resolve this but, I can live with the current outcome…

My attempts to resolve included various settings and Origin usages in both KiCad and CopperCam.
The current, Dialed-In (KiCad) settings and results, are very good and my only complaint is an Offset of the PCB’s perimeter (Edge-Cut) that happens when loading a layer containing the Perimeter Shape.

The cutouts and graphic holes are on User Layers. Results are Perfect!
The PCB shape is on the Edge-Cut layer. Results are an Offset Shape Contour.
If I draw the shape on the User Layers, those layers get Offset (just like the Edge-Cuts).

[Note: was able to make/include rectangular cutouts for Flat-Contacts on Barrel Conc FootPrint (Very Cool - Thanks KiCad folks!]

I use the Offset feature in CopperCam to correct the Edge-Cut layer. It’s a minimal extra step.
[click to expand the image] if needed

I can’t really tell much from the screenshots. There is no particular reason why the edge cuts has an offset. Perhaps if you posted the gerbers we could tell more.

Edit; the grid origin does not affect the output to gerbers, but the auxiliary origin would.

Thank You for response.

I’ve played with the Origins, the Auxillary shows attached to the preimeter but, the layer is still offset.
Also, it’s a graphic element (as seen by CopperCam and gets included as part of the perimeter so, I have to manually delete the circle and two lines; it’s more bother than simply offsetting the layer.

Gerbers attached. Also, as part of my trial-tests, I played with what gets saved… The current settings work best, the image attached…

By inspection/measurement in CopperCam, the Offset is about 2.5mm. If using the Auxllirary origin, the Offset grows to 5.0mm

pcb_WslotPLAY-Btm_Copper.gbr (3.4 KB)
pcb_WslotPLAY-Eco1_User.gbr (861 Bytes)
pcb_WslotPLAY-Eco2_User.gbr (629 Bytes)
pcb_WslotPLAY-Edge_Cuts.gbr (713 Bytes)
pcb_WslotPLAY.drl (633 Bytes)

… Added…

Interesting (probably Solved). I opened all the Gerbers in Cuprum Gerber Viewer and everything looks properly aligned.
Thus, must be a CopperCam problem… Image loaded into Cuprum attached (faint lines but see-able)

I had a feel-able response to this neologism to replace visible, so I coined one to replace palpable. :wink:

… here’s another ‘neologism’; I’m ‘confuse-able’

More to the point:
After enough hair pulling, I discovered the problem is KiCad (not CopperCam).

Using KiCad 5.1.5-0

I created a new project without using a template.
Setup the stuff I need.
Saved Gerbers.
Loaded into CopperCam.
All Was Good.:grinning:

I Saved that project to Templates Folder. Added the Meta folder/files.

I created a new project using the Newly saved template.
I opened the PCB and added a few footprint/traces.
Saved Gerbers and loaded into CopperCam.
All Was BAD :confused:

I created a New PCB in the opened project and added a few footprint/traces. (i.e. did not use the PCB that was part of the Template).
Saved Gerbers.
Loaded into CopperCam.
All Was Good. :grinning:

I observed TWO differences :frowning: - Gif Video and Image attached:

  1. The PCBnew Windows are NOT the same.
    The one from the Template has two Icons at top left.
    Saving the Gerbers lists a message about “… X & Y Scale being Constrained

  2. The PCBnew window, created from starting a New Pcb does NOT have the two Icons at top left and does NOT issue the message about “… X & Y Scale being Constrained

Perhaps that’s the way it’s intended/designed to work? Perhaps a ‘Bug’ ?

Not a bug.
The one with 2 extra icons is pcbnew in stand-alone mode. There are 2 flavors of pcbnew: “normal” opened within KiCad application, or KiCad launcher, call it as you want; and pcbnew stand-alone, opened directly.

Standalone version lacks of all the stuff related to the schematic, for example. On the other hand it has the possibility to append extra boards.

I can’t say whether the bug is due to the standalone version or the template managing module, sorry.

1 Like

Thank you.

Today I made some tests using Both versions (Stand-Alone and (I’ll call it) Integrated).

Yes, there are differences between them. But, the results indicate it doesn’t matter which PCBnew is used and doesn’t matter if using my Templates or starting a New Project without my template.

In all tests, the Trace and Cuts (and other) Layers are good with respect to CopperCam (C.C.)
The Drill File (and individual NPTH and PTH) sometimes works, sometimes Does Not work.

When it does Not work, the locations of the drill holes are a Magnitude off!
(i.e., Example: Should be at x=35, y=60 but, load in C.C. at x=350, y=600).

There are options in C.C. for compatibility and I tried all of them, Including Import Scale of Gerber and Excellon, trailing, leading and decimal zeros… Did not help.

True, it could be C.C. (and that I’m running it on Mac/OSX via Wine) but, I don’t have problems loading drill files from Fritzing.

I did come away from this testing with a more consistently-reliable approach, as follows:

  1. Start a project with my Template
  2. Add Directory for the Output files
    • Set Dir location and Delete the " ./ " in field and type Dir name
    • Refresh
    • Quit KiCad
  3. Restart KiCad
  4. Open the PCB file and Add components & traces…etc
  5. Export/Save Gerber “Drill’ File”. In This Order:
    • Ensure Aux Origin is Checked
    • Generate Drill Files
    • Close
  6. Export/Save the Other Gerber Files:
    • Ensure Aux Origins is Checked
    • Plot
    • Close

(In C.C)
File>New>Circuit (load the Cu.B and other Cu layers, if not single sided board)
Don’t Re-Frame (uncheck the box), OK
New>Additional Layer> (load the Cuts (and Drawing Layer) if needed)
New>Drills> (load the Dril file).

The above results if the most consistent process (for me). It eliminates needing to shift/align layers.

FYI - C.C. is not Open Source but, the limited-use version (same as Paid-For version) is Free and a good way to test compatibility (and make some small circuits). This is the link

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.