Ooops OMG no parts in libs?


#1

Have I killed my K5 install ?

there are no components in the libraries…
I already reinstalled back into the default folder, still no parts ??
Sorry I broke it, and asking how to fix…

only the lower case libraries have parts?
no parts:

Please tell how to rescan libs or reload… thanks guys.


#2

Could you show the content of the sym lib table (via the library manager found in the preferences menu)

Maybe also the path setup from the preferences menu of the main window.


#3


#4

Could you look with the file manager under C:\msys64\mingw64\share\kicad\library? I would guess this directory is empty or non existent. (I would guess the KICAD_SYMBOL_DIR should point to C:\Program Files\KiCad5\share\kicad\library)


#5

C:\msys64 does not exist :~

I remapped the path as you suggested
and it worked…
I loaded a LQFP all good thanks…


#6

LQFP is a footprint not a symbol. Footprints are not controlled by that setting.


#7

it works !

Sorry, Yes, I loaded a STM32 into the schematic, all good, thanks… my bad…

Tooo many aspects for toooo many systems.
From Angular in JS to Electron, from POCO server to AWS and now we have the PCB :slight_smile:
STM32 HAL CMSIS UARTS SPI QSPI CRC AES128 IIC IrDa CanBus Ethernet LCDs and other stuff
Algorithms, Calculations and State Machines… where does it end ?
sooo much stuff, how to be conversant with every aspect ?

Other than that, not much to do…

Thanks


#8

There was a bug in the windows build that has been resolved as of the 2018-06-27 nightly (x86_64 archive linked). See https://bugs.launchpad.net/kicad/+bug/1775796

I don’t know if this would resolve issues in existing installations, but we shouldn’t see this issue with new installs.


#9

Finally after many years. The previous msys64 was just wrong for nearly every Windows user


#10

I believe KiCad saves the value when it for the first time tries to find a default. So it won’t be fixed for older installations.