One symbol library on CIFS filesystem not loading

I have defined 10 Project Specific Symbol Libraries. They have the same names as the KiCad shared libraries so they effectively replace those. The project is on a CIFS file system (Windows Share) and the symbol libraries are in folders in the project directory. I know this is supposedly asking for trouble, however, it’s been working fine with both symbols and footprints… until now.

I now have one symbol file, Transistor_FET.kicad_sym, which will not show up in the Symbol Editor. Transistor_FET is empty, so it is clearly aware of the Project Specific Library definition, otherwise it would be showing the System Shared libraries, but the tree item is simply empty and not error is produced.

If I Import the symbol file Transistor_FET.kicad_sym it loads and shows up in the tree as a new item, so there does not seem to be an error in the file. If I then save the imported symbol it renames the original to Transistor_FET.bak and then writes and identical Transistor_FET.kicad_sym. But when I close the Symbol Editor and then re-open it, the Transistor_FET tree item is empty once again. Meanwhile, the other 9 Project Specific libraries are fine.

I can’t see and difference in the definition that would cause this. What might the problem be?


Did you try closing the entire KiCad program to flush all files to the CIFS share? Can you examine that symbol library with a text editor?

I tried, and it worked for me. :ok_hand:t5:

It appears to be some kind of caching issue. KiCad is inconsistent when deciding when it needs to reload symbols and footprints. Eventually it just showed up, and I believe I triggered that by changing something else that was completely unrelated.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.