Old library after upgrde to 5.02 (wxDateTime)

I have just updated to Kicad 5.02 and get this error:


I recall setting up a MASTER folder for my library edits, but I’m not sure if it’s still there.

I don’t mind starting again.


This exception has nothing to do with the symbol or footprint libraries. It looks like some wx dependency makes problems. I suggest you post the full kicad version string.

Hi R,
Is this what you asked for?

Application: kicad
Version: (5.0.2)-1, release build
wxWidgets 3.0.4
libcurl/7.61.1 OpenSSL/1.1.1 (WinSSL) zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) nghttp2/1.34.0
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.68.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.61.1
Compiler: GCC 8.2.0 with C++ ABI 1013
Build settings:

Any particular reason to update to 5.0.2 instead of the current stable 5.1.2? I see you are on windows, and the 5.1.2 stable for Windows has been available since 2019-04-26 (just over a week ago). Or am I misunderstanding your use of “just” to mean today or yesterday? :wink:

I’m not sure if upgrading to the latest stable will solve this issue, but AFAIK only the 5.1.x is currently getting bug fixes. I would consider the 5.0.x branch as frozen. (I’m not a developer, and I can’t speak for the developers. I’m just stating what it looks like from a general user point of view. I do remember recently one of the people with the little Ki badge on their avatar mentioning something about a fix being targeted to 5.1.3, so hopefully bugfixes are still being worked on for the 5.1.x branch.)

P.S. Please remember to use both dots when referring to version. Each number in the tuple actually has meaning so misstating the version number can cause confusion. I’m not trying to berate you, I’m sure I’ve made that mistake as well. Please take this post-script as a gentile reminder.

1 Like

Hi S,
A poor use of just!

The version I have is [ kicad-5.0.2_1-x86_64 ]

The version I previously had was [ kicad-5.0.2_1-x86_64 ] and perhaps I’ll put it back, until I work out which version to use.
Thanks, C
P.S I don’t take offence easily, when someone id being helpful :slight_smile:

Can you review the version numbers you’ve just posted?
Seems that you have “upgraded” to exactly the same version you had previously ("[ kicad-5.0.2_1-x86_64 ]")

Hi F,
A bit of dyslexia creeping in :frowning: I got mixed up with the previous version, it should read [ kicad-5.0.0-x86_64 ] I hope it’s correct this time.

I have two computers, a desktop and a laptop.

On this desktop computer, the later version is ok.

On the Laptop, I have just (10 mins ago) un-installed the later version a re-installed the older version, and I’m getting the same kind of error.


Since it’s a “datetime” error, can you check what is your system time/date setting? Maybe for some reason your system’s RTC is set wrong

As @SembazuruCDE pointed out, 5.0.x is an older version and the latest version for Windows is 5.1.2. Any reason for not updating to 5.1.x - the newer version has the benefit of many new features and bug fixes?

1 Like

Hi J,
I don’t have broadband, and get large files elsewhere, as I had a previously working 5.0.0 and a 5.0.2-1 to play with, I used those as tests.

Hi F,
It’s possible you may be on the right track. The laptop is ‘faulty’ with both the above Kicad versions, so it looks like the problem is here.

Last week I stripped the laptop to fit a new fan, so many connections were dis-connected, maybe it was this that cause the problem?

The Date/time is ok


I found the problem! Not a Kicad problem.

Previously, I did all of my work on the desktop, until it filled up, so I moved folders into proper locations on the disk-drive, then made links on the desktop, including the Kicad folder, so when I installed the later version, nothing connected.

I’ll try to remember next time, thanks for your patience.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.