Odd Net value Reassigned somewhere along the line

I have a net named INT\ in the schematic I use ~{INT}
However somewhere before today it change to:

I found other nets changed as well

Is this an issue with the ~{ xx } syntax?

Application: KiCad PCB Editor (64-bit)

Version: (5.99.0-11043-g1a35d8ba5d), release build

wxWidgets 3.1.5
libcurl/7.74.0-DEV Schannel zlib/1.2.11

Platform: Windows 10 (build 19041), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Jun 15 2021 21:01:02
wxWidgets: 3.1.5 (wchar_t,STL containers)
Boost: 1.75.0
OCC: 7.5.0
Curl: 7.74.0-DEV
ngspice: 34
Compiler: Visual C++ 1928 without C++ ABI

Build settings:

In the latest file format change (I think 2021-06-06 or there abouts) the change was how “inverted” names were handled in the files created by KiCad-nightly.
Maybe just coincidence, maybe it’s a hint…

They reverted back to the expected after updating the board from the schematic. They many have been that way for some time. I hadn’t been working in that area for a while.

There came also bugfixes to the new syntax after the original change was introduced. It’s unclear to me if JohnRob’s latest message means that the problem was solved.

I guess its solved being that the net was reverted to the original with a reload of the board. I think the issue might be resolved as a previous version of my board had the same issue and I can’t imagine I hadn’t reloaded is somewhere along the line.

So I’ll asy SOLVED but will continue to watch for it reappearing.

There were several bugs when we converted to the new syntax. I think they’ve all been fixed, but if you saved with a bad version you might have to fix some strings yourself.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.