Odd Footprint Mounting Hole Behavior - Now you see it, now you don't

Re: (5.1.5)-3
Windows 10 - 1909
See attached jpeg. I didn’t know how to include it within the text. Sorry.

The picture on the left is the footprint of a big resistor, with its heat sink housing, provided by TE Connectivity, via Ultra Librarian.
It is opened within the footprint editor. I have not found a way to see its mounting holes, within the editor. The holes are there, however, as they can be seen, in a particular manner, when the footprint is on the board. See following.

On the right are two copies of this resistor, placed on the PCB board, in no particular fashion. The one on top is selected/high-lighted and, while highlighted, it displays the mounting holes. You see that the lower resistor, not being selected, does not show the mounting holes.

How do I get the mounting holes to appear permanently on the footprint, within the editor and on the board?

Thank you for your help!

I suggest you check the pad settings of the “mounting holes”. For reference this is a footprint (if necessary via a text editor) for a similar component that i designed a while ago. It works as one would expect it to work so you can compare your footprint to it. R_HS15.kicad_mod (4.1 KB)

The pad in question of my footprint looks like this:

(pad "" np_thru_hole circle (at -7.15 7.95) (size 2.8 2.8) (drill 2.8) (layers *.Cu *.Mask))

Notice that size and drill have the same dimension.

Good that you figured out how to add a NPTH hole to a footprint.

To make it show up in other PCB layouts, you need to Edit your ‘Library’ footprint.

Editing only the Footprint of the current PCB only affects the current PCB…

Damn i misunderstood the question. You are on the right track. However to add more info: If one edits a footprint placed on the PCB then only this one single instance will get the change. Even other instances of the same footprint placed on the same PCB stay different if the library footprint is not changed.

Also after changing the footprint in the library the ones on the PCB need to be updated from the library.

Thanks, folks. I appreciate the help.

I can not change the pad settings, on the mounting holes, because the mounting holes do not show in the footprint editor, as I explained. And, the holes can not be selected as a separate item, in the component board settings.

I was hoping there was some setting that I do not know about. Like this was some type of known method that was used for a reason. I guess the files are just corrupted.

When making a footprint, you can use pads from a list Or, use the Pad Icon/tool.

Example uses Pad/Icon tool.

I did not fuss with it and forgot to make a PCB shape (edge-cuts) until it didn’t display. I corrected it in the attached…


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.