Obscured added text in symbols

During the last couple of days I have been fighting with an issue. I attempted to add text to a symbol, but when I finished the process the text vanished.

I cannot easily show the problem right now, as I have experimentally fixed it using Notepad. But in the image below, the portion of “experimental text” that was within the rectangle was invisible. This is a view from within the symbol editor:

Based on my fix in notepad, It seems that the parameter in question was no fill versus black fill for the symbol rectangle. Apparently the added text gets rendered behind the fill color. That does not make obvious sense.

I do see preferences > “Use schematic editor color theme” but how does that affect a symbol which I have recently/previously created?

Another confusion factor: In notepad it seems that my symbol definition “Test_Symbol_01” is (followed) by symbol “Test_Symbol_01_1_1.” I first tried setting the first fill color definition to “no fill” but that did not work. I then found the second symbol definition and also needed to set that fill color definition to “no fill”. I am glad my name is not “Phil.”

What is the normal/correct way to work this?

In the text editor, I noticed a fill color (for this symbol) of 0,0,0 but I cannot figure out the normal way to edit that from symbol editor?

EDIT: In fact I do have an original symbol (I do not want to show that one) on which the problem is not fixed. When I tried inserting that into a schematic diagram, there is absolutely nothing visible within the symbol rectangle. No pin names, no reference designation, nothing…

Application: KiCad Symbol Editor x64 on x64

Version: 8.0.2, release build

wxWidgets 3.2.4
FreeType 2.12.1
HarfBuzz 8.3.0
FontConfig 2.14.2
libcurl/8.5.0-DEV Schannel zlib/1.3

Platform: Windows 10 (build 19045), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Apr 27 2024 23:05:17
wxWidgets: 3.2.4 (wchar_t,wx containers)
Boost: 1.83.0
OCC: 7.7.1
Curl: 8.5.0-DEV
ngspice: 42
Compiler: Visual C++ 1936 without C++ ABI

Build settings:

These are the four available choices for body fill with examples.

Additional text will only show for “A” & “C” inside the symbol.

“Fill with body background color” can be altered in Preferences > Schematic Editor > Colors > Symbol Body Fills but only if you are using a read/write color theme.

An interesting phenomenon: I created A,C & D by Duplicating. If I then duplicate the duplicate using B or D, the text appears inside the symbol on top of the color; but, as soon as I perform any function on the schematic, the text is then hidden behind the color. I think I have found a very little bug. :grinning:
See below:


Duplicating the duplicated duplicate results in the text being hidden, as it should. (I thought you might like to know this just in case you were worrying about it). :slightly_smiling_face:

Thanks, Janek

But I think you lost me…

FWIW I am recently running KiCad on both my Win11 personal laptop and on my Win10 employer’s laptop. I have seen this issue only on my employer’s laptop. But I am a contract engineer and that laptop will be gone in a few weeks.

What is that?

I do not understand. Why would I ever want the text to be hidden? EDIT: Perhaps you are pulling my leg…

Also, how does schematic color preferences affect what I see in the symbol editor?

FWIW I also do not know what is the point of symbol color fill. I suppose it might make the schematic look prettier in some situations, but I do not value that. It reminds me of some shenanigans with Microsoft Visio, where they add shading to shapes which makes them look vaguely 3-dimensional. The Visio shading is a good way to balloon the size of any resulting .png files for example. In both cases, I do not think it adds clarity (moan & complain). Anyway I never intentionally use symbol color fill in schematic symbols, except that today I was experimenting with it in order to diagnose this issue.

Only A & C will allow anything inside the border to show. If you select C rather than D and fill with black, it will have visible writing over the black.

If you are using a “read only” color theme you can change to read/write by opening the theme box, adding and naming a new theme WHILE you have the current read only current theme displayed.

Colors for C can only be changed if you are using a “Theme” that is not “read only”. See as in my above post.
Preferences >Schema Editor > Colors

Click on the triangle in the theme box to see the various themes installed. If the theme you are using is read only, the color won’t change for “symbol body fills” , however, if you select the B or D option, you can change the color for that symbol only, but overlapping text is covered.
“Symbol body fills” is a global setting that alters all fills on all Schematics.

Thank you for your attempt, Janek but I am still lost.

  1. When I go to Preferences>Preferences>Schematic Editor>Colors>Symbol body fills I get this:


  1. I have never seen this menu (image copied from your post)

    Please tell me where is that menu?

  2. A day or two ago I noticed that there was NO TEXT appearing inside my symbol rectangle. Zero, zip, nada. No pin numbers and no pin names. I see pin names in your ABCD example.

  3. Why would I ever want all of the text inside a symbol to be obscured?

  4. I still have no idea about “read write color theme”? What does it mean and how/where do I specify that?

Symbol editor.

When I go to Preferences>Preferences>Schematic Editor>Colors>Symbol body fills I get this:

Yes, but you can only change this color if you are using a personal color scheme.

After you have changed the color for the fill, you then need to open the symbol properties for the rectangle by clicking on the border of the rectangle and that properties panel will show.
Click on A for no fill or C for Personal Color Scheme. Clicking on B or D will block the writing.

When you go to Preferences > Preferences > Schematic Editor > Colors is your Theme (Read Only):

OK…My Theme is BobZ3. I have generally been using that.

The rectangle…How do I open the symbol properties for THAT RECTANGLE? Nothing happens when I click on the rectangle outline here:

If I open the symbol properties for something else, I get this

So I still have not found these 4 options anywhere.

Perhaps this is mostly moot, in that I am not interested in using fill colors. I went into a text editor to change the fill to no fill.

So…getting back to the original question, what would be the normal way of removing fill from a symbol?

The rectangle border of your symbol in your schematic or symbol editor, then your Rectangle Properties box shows, with the fill styles.

OK. I did not know whether it needed to be a rectangle, and I thought you were referring to the dialog box which you were showing me.

I also did not know of that method for getting to “properties”. That gives me this menu:

So this is progress (and it shows me how to make Phil go away) but it differs from your image. Still I get no A,B,C,D. I don’t feel that I need that, but I still wonder…

I GUESS that showing no color for border and fill means that I get default colors chosen elsewhere, except that I choose do not fill." (??)

If I want a seclusive OR gate, I suppose I would want to fill the symbol with camouflage. :crazy_face:

I like to see her whole name on a very pale black phil.
I placed the ABC&D with my screen-grab programme to save a lot of typing. See my last post for what Kicad supplies: just the -ve of yours.

Thanks again Janek.

I cannot help but wonder if one issue is us being “divided by a common language.” (Usually said of Brits and Yanks.) The latest case in point: I have no idea what you mean by

But I hopefully have figured out how to make Phil go away. BTW I think of:


who was very big on American TV when I was a kid. I have no idea whether he was popular on TV in your neck of the woods…

As I’ve mentioned before lycanthropy is the (mistaken) belief that one is a wolf so philanthropy must be the belief that one is Phil. Are you rid of your philanthropy now? :rofl:

Welcome to this mad discussion. Maybe I am just Phil of it.

In this forum I do not remember anyone else as prone to text editing as a quick fallback workaround for issues which are not easily understood. It is refreshing that it can be used relatively easily (or I would not be able to do so.)

The properties panel you display has black print on a white background. The properties panel I display has white print on a black background; hence my panel is the -ve (negative) of your panel.

But, on closer inspection, I have a Rectangle Properties Panel, but you have a Polygon Properties Panel.

Perhaps we should stop worrying too much about Phil and Philomena and start looking for where your Poly has gone? (the word polygon always reminds me of the Monty Python dead parrot sketch)

I don’t remember Phil Silvers, or if that show was on our TV.

Sounds like a panel discussion. I like “knotty pine.”

And I was going to say something about “Polly Wanna Cracker” but you sort of beat me to that detour.