Novice Question: Cannot pour ground plane


#1

I’m a brand new KiCad user, coming from Eagle etc, and working through the “Getting Started in KiCad” tutorial. I’m stuck at step 26 (pouring a ground plane). I end up with hatch marks around the edge of the board, but not a fill – I’m sure this is a simple cockpit error.

Before the fill, my board looks like this:

In the fill dialog, I’ve selected the B.Cu layer and the GND net:

But when I complete the outline, I only get a cross hatch around the edge, not a full pour:

What am I missing?

(P.S.: Yes, I know I should not be using a DC barrel connector for this particular circuit – I’m just experimenting.)


#2

For your own sanity have a look at the new canvas (opengl reachable via F11 or the view menu)
It has some nice new features. (Example: interactive router, interactive drag, …)

Regarding your question: Did you press “B” to “refill” the zone?
You get a list of shortcuts via the shortcut “?”


#3

Left menu below the icon with the red X is the icon to show the fill zone.


#4

When the “Add Filled Zones” tool is active, you can also just right click and choose “Fill or Refill All Zones”. (This is the same as the “B” shortcut that Rene mentioned.)


#5

Well that worked in an unexpected way!

For your own sanity have a look at the new canvas (opengl reachable via F11 or the view menu) It has some nice new features.

One “feature” was that it captured my cursor, so once I’d started the pour outline, I couldn’t move the cursor out of the window in order to click “Okay” on the Copper Zone Properties dialog – instead the cursor stayed in the pcb layout window and started autoscrolling. :confused: I had to switch to another app and back to free the cursor.

Did you press “B” to “refill” the zone?

Once I completed the outline in OpenGL mode, the fill showed up without typing B.

For completeness, I undid the fill and switched back to default view mode and repeated the process. This time it did not capture the cursor (as it had in OpenGL view mode), but DID require me to type B (“Fill or Refill All Zones”). And voila – the fill appeared.

That solved my problem - thank you.

Post-facto analysis: The tutorial says “Right click inside the area you have just traced. Click on Fill or Refill All Zones.” As far as I can reconstruct, I did right click, but somehow missed that menu item.


#6

I think we had a similar report by another mac osx user here.
(Sadly i can’t find the topic anymore.)
It seems kicad stable is a bit buggy on osx. (some new features have been added to nightly that should make the experience for osx users better.)
But nightly added a lot of new bugs as well so i would not suggest anyone new to the software uses it!


#7

I think you have to ‘hit’ the edge of the zone, not just somewhere in the zone area to get the menu for the zone.


#8

A shortage of developers and serious users on OSX


#9

I always just right-click in the middle of the zone and don’t have any problem. (I’m using legacy mode, not OpenGL.) The important thing is that the “Add filled zones” tool has to be the active tool. If one of the other tools is active, then “Fill or Refill All Zones” does not appear on the right-click menu.


#10

Ah! So I wasn’t just being unobservant. Thank you for the tip.


#11

No tool selected, either Legacy or OpenGL canvas, right clicking into the hatched area of the zone (or on the edge/nearby) will get you this:

If there is anything else there, there will be a subselection, and ‘zone outline xyz’ will be an option there.