Not one single component I add is visible in board editor

I have checked my library file paths however every single component I add has a question mark on it. None of them show up in PCB editor - I get a blank canvas every single time. I have tried following this tutorial : https://docs.kicad.org/6.0/en/getting_started_in_kicad/getting_started_in_kicad.pdf

However I get no result.

What do you mean by that? Does the reference designator have a ? like “R?” ? if so you have to do an annotation.

kicad_toolbar_annotation6mMddZLLkp

You should also check if every symbol has a footprint assigned

kicad_toolbar_footprint_assign

1 Like

For PCB editor the terminology is footprint. For schematic it is symbol.

Did you make a schematic, and was the result successful?

Thank you for getting back to me. Here is my schematic - I ran the annotation tool, however the PCB layout remains completely blank. I would like to generate a schematic then have it show up on the pcb layout and not have it completely blank as shown here regardless of what and how many components I try to add.

Here is an image of the empty pcb layout I am getting. I have tried to run the annotation tool but every component I add refuses to display in PCB layout. Any help would be appreciated.

Did you hit F8 in the schematic editor? It switches to the board editor and loads the netlist/footprints there.

Thank you - I tried but it is still not populating board editor. I even tried loading an existing project and adding a component to it - nothing I add displays in PCB editor. Vice versa if I add a footprint to PCB editor and switch - nothing visible in schematic editor.

Assuming the schematic is annotated and there are footprints assigned to the components;
After “Open PCB in board editor” is clicked and the PCB Editor appears, try hitting F8 (“Update PCB with changes made to schematic”) in the PCB Editor.

As a step in problem solving this…

Open PCBnew and start a new PCB (not schematic)

Place a Stock Footprint or more on the PCB. Does it get placed?
Can you view it in the 3Dviewer?

If so, that eliminates PCBnew from the problem equation.

Thus, it’s down to the Paths you set up. I’ve had countless similar problems with the ‘?’ showing up on schematics after I upgraded… All of my previous GOOD projects required my manually resetting the link/paths… I’ve posted about this (my) problem before and the only solution for me was to manually redo the paths…

This looks like the footprint assignment stage is missed

I concur with davidrsb.

The workflow is Schematic → Footprints → PCB edges → Update from Schematic → Layout → Traces.

That does seem the most logical explanation.

Run: Schematic Editor / Tools / Update PCB from Schematic [F8] and then read and interpret the error messages. There is also a [Save …] button to save the messages to a text file so you can post it here.

I agree too. Sort-of… I assumed @tryitagain stating he/she “followed the tutorial” meant to me he/she added the Footprint.

You can have a Schematic Symbol without Footprints assigned.