Not impressed with V5

I’ve only been using V5 for an hour or so and I’m going back to 4.07.

  • When routing tracks, I now have to “Shift-V” to place a via to change layers. In 4.07, all I had to do was “click”, change layers (page-up or page-down) and keep routing. Kicad automatically inserted the required via.
  • I can’t “break” a track in V5. In 4.07, all I did was right-click on a track and select “break”.
    I’m wasting too much time relearning how to do basic tasks.

I do not understand.
I just layed a few tracks in KiCad V5.0.2 and it “simply works” the same for me as I was used to in the old V4.

While routing a track I just press “V” and a via gets attached to the mouse cursor ready for placement.
[PgUp] and [PgDn] also work for changing layers.

And if I right click on a track I can also select “break” from the menu and it breaks the track at the mouse pointer position.

Maybe you have lost the Hotkeys somehow.
What does it look like when you:

Pcbnew / Preferences / Hotkey Options / Edit Hotkeys

I just exported my Hotkeys, maybe you want to compare them with your settings.
pcbnew.hotkeys (6.2 KB)

Plain “V” works for me and has always worked. KiCad inserts a via and continues routing on the other side. How would that be more difficult than pressing PgUp or PgDown?

In routing mode open the context menu as paulvdh says, there’s “Break Track” there.

  • When using pgdn and pgup, I select the destination layer and Kicad does the rest. Wouldn’t make a difference if you are only doing double sided boards.
  • I need to be able to “break a track” when not in routing mode. If I’m routing, I’m laying tracks, not editing them. Seems counter intuitive to me.

If I understand correctly you would like PgUp and PgDn to cycle through the copper layers instead of just switching between front and back?

I can easily select a track, right and press break track without being in routing mode.
I’m using newest nightly, not sure if thats the difference

Yes. In 4.0.7, I started drawing a track, clicked to set where I wanted that track segment to end. I then pgup or pgdn to the next copper layer and kicad “rubber banded” the next segment on the new layer. When I clicked the location of the new segment end point, Kicad would lay that track on the selected layer and automatically insert a via (through hole, blind, half blind, etc) at the last transition point.

When I select a track (left click to highlight a track) and then “right click”, I don’t see “break track” in the pop up menu that appears. I’d send you a screen shot but my prtscr doesn’t work when a pop up menu is present.

Can you possibly test with newest nightly?
5.1 is about to be released, so if it’s should be fixed, now would be a good time :slight_smile:

Yes, that seems to be a difference between 5.0.2 and the latest nightly build.

If that doesn’t work in a later version I would consider it as a regression and should be treated as bug. Please report it to the bug database, there’s a good chance that it will be fixed for 5.1 series.

Not a regression, just a change in workflow in GAL vs. legacy to support additional routing options. Workflows may change between versions. Working with a new version for 1 hour will probably feel very different for the op, especially if they were very used to 4.0.7.

In the case of the via, we have removed the “implicit” via of the legacy canvas because it prevented routing in close tolerances, especially when you didn’t want to place a via at all. If you recall, legacy routing always had the via at the end of the track. I’d venture that the workflow is not more difficult to to do route->‘v’->Click->route than to do route->click->PageDown->route and it is more flexible.

So how do I route to an internal copper layer?? My (limited) exposure to the new way is ‘V’ creates a via to the opposite side of the board.
I don’t recall having a via at the end of a track in the old system. If I finished a track segment on the current layer, it stopped on the current layer at a dead end.
The current workflow IS more difficult than the old and not as intuitive.
As mentioned previously, under the old, I could hover over the start of a rats nest segment and press ‘x’. Note I didn’t have to enter the “routing” mode first; Kicad was clever enough to figure out what I wanted to do.
A rubber-banded segment would start on the current layer and I could move the end point to where I wanted. Note that a real track was not put down at this point. If I was on the wrong layer, I could pgup or pgdn to cycle through the available copper tracks. Once I clicked, THEN the track was laid down on the current layer. I continued to move and click, laying down tracks as I went. Note vias were not placed anywhere yet.
When I wanted to change layers, I cycled through the available copper layers until I got to the one I wanted and the rubber-banded track reflected this. No via has been laid yet.
I then moved to the next point and when I clicked, Kicad would draw the track segment on the new layer AND automatically place the required via (through, blind, half blind, etc) at the point where the layers changed.
More clicks and key presses does not improve a workflow.
Same goes with the “break track” function (which I found by accident); I have to be in the routing mode to have this appear in the right click menu.
Under the old version, I just hovered over a track segment and when I right-clicked, Kicad was smart enough to figure out I wanted to edit that track segment, so gave me the track edit pop-up.
If there was more than one item at that location (e.g I had hovered on a track segment under a component), Kicad would ask for “selection clarification” before it provided the appropriate pop up menu.
Seems to me the current version is a step backwards since Kicad appears to have lost a lot if it’s smarts.

V always moves you to the opposite layer as defined in the layer pair setting. (See Tools -> set layer pair.)

You can also use the + and - keys to change the layer of the currently not yet placed track segments. (After placing a via you can select the new layer using these keys.)

Are you sure you do not confuse “intuitive” with “i was used to the old quirks”?

Thanks. I’ll try the + and - “quirk” and see if it does what I expect…until that changes.
“Intuitive” to me means easy and logical (i.e make sense). I may be stuck in the “old ways” as you call them, but they worked; they weren’t broken. The simple, uncomplicated processes were the main reasons that drew me to Kicad from Eagle. I didn’t have to read pages and pages of documentation to do the basic things. That should tell you how “intuitive” Kicad was. If it ain’t broken; don’t fix it. Change just for the sake of change is silly.
I’ll now step away from the keyboard and take my medication.

Just tried + and -. Whilst I’m routing, + and - do change the layers but subsequent segments are not placed on the newly selected layer; in fact the layer reverts back to the layer selected when the segment was started. Not sure what the point of this function is if it keeps changing back.
In so far as the key selection, + requires “shift” to be held unless you have a numeric keypad.
As a suggestion, changing layers could be done more quickly with the scroll wheel on the mouse.
Combined with the functionality in the previous version, this would be a VERY FAST way to lay down tracks on multiple layers.


Hi Frustrated-

Please see if some of your workflow could be addressed by mapping the hotkeys to your preferred keys. For example, if your hotkeys current have Shift+V as the via command, you can edit the hotkeys to just use ‘v’. Likewise for the “+” hotkey. You can re-map that to “=” to avoid having to use the Shift modifier.

Your suggestion for switching layers using the mousewheel is an interesting one. We’ve been looking at allowing customization of mouse events in v6. I’ll add layer switching to the list of options that could map to it. Thanks!

1 Like

My current workflow cannot be addressed with hotkey assignments because the layer changes as suggested do not work when routing. i.e + and - DO NOT place tracks on the selected layers. Try it and see for yourself.
Could you add the routing functionality that was in 4.0.7 as well please. The old way is definitely the fastest and more logical. Vias are placed “because of” a change in layers; not the other way around.
Some call them “quirks”; I call them features.

Read my comment again. You first place the via and can then select on which layer to place the new route.

Alternatively you left klick to fix what is currently routed and switch to the layer with +/-.

The reason why the interactive router can not simply place the via in this case is that with it you potentially have a much longer trace that is not yet fixed. So it can not know at which point you want your via to be placed or which part of the trace should go on the other layer.
(The old legacy router always had at most two trace segments that are not yet fixed. There is no limit for the interactive router. Unless you set it to highlight collision mode.)

Meaning the new workflow is a bit backwards to how you used it. You selected the trace first and got the via later, now you need to fix the via position first and then select how to continue. (You can still end a trace without a via at the end with leftclicking. This fixes the currently drawn trace at the last direction change.)

If you truly are that unhappy with the workflow connected to the interactive router then you could still work with the legacy toolset (F9 is the default hotkey to switch to it. Or use the entry in the view menu.)
Be aware that this toolset will go away at some point in the future.

1 Like

Thanks for this. Switching back to the legacy toolkit did it. I will now fix my version to the current release with legacy toolkit.
As a bonus, a filled zone doesn’t cover up everything else. I didn’t mention it before because I couldn’t remember if it was like this in 4.0.7.
In summary, when a filled zone (e.g ground plane on the top layer) is shown, it covers everything else. Using the legacy toolkit, the silk screens still appear “on top of” the filled zone.

Additionally, the “break track” appears where I expect it to. i.e I don’t have to be in “route” mode.
I can also start a route by hovering over the start of a rats nest segment and press ‘x’.
I now love Kicad again…:grinning:

There are 3 visibility modes for filled zones. Filled, result outlined, construction polygon only (My interpretation of what they do. They will be called differently in kicad)
These are set in the left toolbar.

Additionally: You can set the transparency for layers in the layers “sidebar” (middle click or double click on the coloured square next to the layer name.)

Also the layer selected is always the one shown on top. The blue triangle shows which layer is active.

One does not really need this tool in the modern toolset. One can start or and a trace on any point of another trace. No need to first break the old one. (For this to work you might need to select a fine grid and play with the snap stuff.)

1 Like