Not able to create STEP models with StepUp and Fcad 0.17


#1

I recently learned to create STEP models of my designs using FCAD 0.16 and kicadStepUp and that worked great and placed the STEP file in the project folder. Today I upgraded to FCAD 0.17 and installed kicadStepUp workbench through the the included addon manager. I can still do all the things that are need to create the 3D models but I don’t seem to be able to get a STEP model. I loaded the PCB through the workbench and it does look like it is working since I see the final board in 3D with all the components. However the STEP file in the folder is now something like 2KB in size (as compared to the 10-odd MB sized file that would get created with the earlier FCAD version). I explicitly exported the 3D model and it still is the same size. I tried importing this model into Fusion 360 and it gave me an error saying that its an empty model. Can anyone help?

EDIT: Just kept trying a few more options and there are a few extra steps involved now. You have to create a compound group first and then export that model as STEP manually to get the final STEP model.


FreeCAD 0.17 and 3D STEP export
#2

I use kicad-stepup a lot for individual models and footprints.

Now, with the kicad nightly version or v5.0.0-rc2-dev the step export comes within pcbnew.
And it works seamlessly.
Maurice, Mário and maybe others have done a great job!


#3

This seems to be a FreeCAD question, and not a KiCad question.
Maybe try the other forum?


#4

I’m quite hesitant to use the nightlies since it seems to replace the existing stable version that I have installed. I do a lot of production work on the stable version and I can’t have the nightlies messing that up in any way. Hence not been able to test any of the new features in V5 yet.


#5

I’m not sure if its a FCAD issue or a StepUp issue. I’ve posted here earlier with my StepUp issues and Maurice has been kind enough to respond. Please let me know if this isn’t the right forum for this.


#6

Of course is a Kicad question.

Kicad-stepup is the application that binds kicad and freecad.
And its author, Maurice (maui), is a regular participant in this forum.

On the other hand, current nightly V5.0.0rc2-dev is more stable than v.4.0.7. I have both versions on the same machine.
You can duplicate a project, open the board with the nightly version, export the step model and come back to v4.0.7 if you feel more confident.

But anyway, you found the solution with stepup.


#7

Where can I download this version?


#8

Windows: http://downloads.kicad-pcb.org/windows/nightly/
Mac: http://downloads.kicad-pcb.org/osx/nightly/
(I have never tried)

Ubuntu:
https://launchpad.net/~js-reynaud/+archive/ubuntu/kicad-dev-nightly

Also see Testing proposal for new PPA schema (Ubuntu) for nightly builds


#9

First off: as one of the library maintainers i really hope you will add what you make to the official library, especially 3D models :slight_smile:

For some cases the step export doesn’t work on newest FC0.17 due to some bugs with the new OCC implementation

You can read more here: https://forum.freecadweb.org/viewtopic.php?f=10&t=26174&start=410
Posted by the man himself


#10

@Shack thank you :slight_smile:

How do I do this? I don’t have a lot of models per say but I can add whatever I have created.


#11

this is the right place for this post because the issue is mainly related to FC but it is related to ECAD-MCAD collaboration… moreover I mainly get feedback on StepUp here and not on FC forum… :slight_smile:

StepUp has more features than the new v5 exporter, so it is still useful when the pcb is a bit complex and/or the user need to tailor the mechanical output.

Unfortunately, the bug is present even for a simple Part container (which is the base for an assembly of mechanical parts).
https://forum.freecadweb.org/viewtopic.php?f=10&t=28052
I have reported this at mantis
https://freecadweb.org/tracker/view.php?id=3426

The regression is based on the interaction of OCC7.2 code and the FC exporting routines …
Please fell free to add feedback here or even better at the FreeCAD forum, to get more attention to this bug.
The worst is that the bug is affecting the FC stable release, but it was not affect the develop release (now the stable) until a week before the official deploying…
The switch to OCC7.2 without a reasonable period of testing created the issue.

I’m working on a patch to fix at least the STEP exporting, reducing the hierarchy of the 3D board model, but this will depress the ECAD/MCAD collaboration.


#12

the models can found here https://github.com/KiCad/kicad-packages3D

most of what you need to know, is in the Readme.
if you have other questions feel free to ask :slight_smile:


#13

Thank you @maui :slight_smile: I’ll keep an eye and switch back to the 0.16 version of FCAD for the time being.


#14

Thank you! I’ll go through the same this weekend.


#15

I reverted back to a windows version I downloaded a fairly recently, version 0.17.13452 (Git), seems to work OK, but I have not checked if there are any other troublesome bugs that was not yet fixed in it.


#16

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.