Noob question about New Library Symbols

I need a symbol and footprint for an Alps RKJXL100401V Navigation Switch so I decided to draw one as it is not in the library.

I spent a long time drawing the schematic symbol only to be told that I don’t have write access to be able to save the Library. I saved it in the same place as the library cache file. Now I can’t seem to load the symbol and place it on my schematic.

How can I make the libraries accessible so that I can add new symbols in such a way that I can use these symbols in a circuit or re-locate the libraries to a place where I do have write access.

I expect I will have a similar problem with the footprint.

Any help would be appreciated.

It is bad form to attempt to write to the provided libraries as upgrading KiCad will wipe out your changes to the provided libraries. You should create and manage your own libraries for your own assets. See this FAQ entry for suggestions:

Thanks that is helpful. I have now located the library and added it to the project and now I can add the symbol.

1 Like

Sounds like a symbolic victory. :grinning:


More like a Pyrrhic victory.

I did manage to save the schematic symbol in the project folder. But I cannot save the footprint anywhere. I have tried several times to edit the footprint but I always loose my work because KiCAD always defaults to saving it on the C: drive and I haven’t found a way to save it anywhere else.

I have copied all the symbol libraries and footprint libraries to a different drive, one I have access to but KiCAD insists of resetting it’s paths to point to it’s own locked libraries and I can’t seem to create a new footprint because when I try to save it KiCAD has always defaulted back to it’s own path to the program folder on the C: drive.

Even when I change the default paths from within KiCAD I am informed that the change is only temporary and sure enough I haven’t really changed anything.

Library management should not be this difficult.

What I need is my own set of symbols and footprints which can be used in any project, is this too much to ask ?

This should be quite easy.
KiCad itself has no real means to move a project to another loctation, but normally a KiCad project is contained in a single directory, and moving (or copying) a directory should be easy with a file manager.

I suspect there is something wrong with file permissions on a operating system level.

Creating and managing Footprint libraries is usually done from within The Footprint Editor. You can either start the Footprint editor from a project, or load a footprint in the Footprint Editor directly from Pcbnew, and then: Footprint Editor / File / New Library

A footprint library for KiCad is just a folder with a [libraryname].pretty name, and each footprint is a separate file in that directory.

However, that KiCad tells you your changes are temporary is a strong indication you have some problem with file permissions.

Don’t remember exactly, as I have done it 3 years ago, but I just made some directories to be KiCad foortprint libraries and copied there some *.kicad_mod files from KiCad libraries.
Example of such my directory is: D:\KiCad\_PcbLib\C.pretty. Then I added my C library into KiCad Library list and from that moment in Footprint Editor I can open/edit/save each of footprints in that directory. Never noticed any problems with it.
I use KiCad 5.1.10 at Windows 7.

In the end, this isn’t difficult. You just have to add a new (empty) library first.

  • Footprint editor -> File -> New Library.
  • Choose the location in the file system and the library folder name.
  • Add to the global library table (if you want it to be globally available).
  • The new library is now in the library list in the editor.
  • You can save (File -> Save) a created footprint in that library.

A footprint library is nothing but a folder. You can add an empty folder or a folder with .kicad_mod files as a footprint library using File -> Add Library.

The same works for symbols, but a library is a file, not a folder. File -> New Library creates a new library file. You can add an existing .lib file to KiCad using File -> Add Library.

You can create a new symbol or a footprint directly to the new library by opening the context menu of the library -> New Symbol / New Footprint. Then you need only to Save the symbol/footprint and don’t need to select the library while saving.

This makes me think of a possible issue. When you open the Configure Paths... dialog within KiCad are any of the paths greyed out? If so then you may have system environment variables set for those specific names. It used to be normal on Window installs to have system environment variable set by the installer. The option is still there but the selection box defaults to off now (I forget when that change happened). The issue with the system environment variables is when KiCad loads any system environment variables will override the user configured KiCad paths. And, unless you are used to manually maintaining system environment variables on your machine it can be difficult to find where to change them. I might be way off base here, but your situation kinds of smells like this situation.

It might be useful for trouble shooting if you share both a screenshot of your KiCad Configure Paths... dialog window as well as either a screenshot of your Manage Footprint Libraries... dialog window or the fp-lib-table file from %APPDATA%\kicad with a note about the specific footprint library that keeps changing from your intended location back to the C: drive.

Thanks to everyone who responded, I have now solved the problem. I have managed to create a schematic symbol library and a PCB footprint library on the E: drive in a folder in the top level ‘Electronics’ directory. This should suffice. All I had to do was look at the website (thanks for the link ‘SembazuruCDE’) and read the effing manual. Doh …

I have also managed to get these libraries included in KiCAD alongside all the supplied libraries, the only difference being that I can edit mine.

All the supplied libraries and the paths are still locked to the libraries provided with KiCAD on the C: drive but as long as my own libraries persist for new projects then that will be OK.

I have used the schematic symbol and the PCB footprint in my project and they seem to be OK but I will only know for certain that I haven’t missed anything when the PCBs come winging their way from China.

Meanwhile if anyone needs the schematic symbol and PCB footprint for the ALPS RKJXL100401V navigation switch then let me know. I made the contact annotation match the ALPS datasheet so it should be pretty simple to use.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.