None of the KiCad Libraries are loading in {SOLVED}

I hereby certify that I am not simply asking someone else to design a footprint for me.

This is an auto-generated message that is in place on the “footprints” section of the forum. If I remove it and ask for a footprint to be designed anyway, I understand that I will be subject to forum members telling me to go design my own footprint or referring me to a 3rd party footprint site.

So I’ve been using Ki Cad for about a year now version 5.1.10 and all of sudden none of the libraries I created or pre-installed ones want to load in anymore. I even tried uninstalling the program on my computer and reinstalled the latest version, but it still didn’t fix the issue. Can anyone tell me what’s going on here?

Read this carefully:

Pay close attention to the all the diffferent paths.

If the above does not help, include a screengrab that shows the problem.

KiCad does not search for libraries. It only uses the libraries listed in the sym-lib-table and fp-lib-table files. These files should reside in your config directory (on my linux box in /home/paul/.config/kicad).

If something happened to those files, or their directory and KiCad can’t find it, then it can not find schematic symbols or footprints.
When uninstalling (on Linux) it does not touch that directory.
However, if you manually delete the configuration directory (or rename it so KiCad can’t find it) then it re-creates that directory with defaults, and it asks you if you want to create those library table files, or if you want to do that yourself.

Uninstalling on Windows also does not touch the configuration folder. I suspect uninstalling on MacOS is the same. See this FAQ entry on where the configuration files are stored on the different supported OS environments:

Hey everyone, thanks for the suggestions. Turns out I was able to figure it out, somehow my file path and libraries were corrupt but I redownloaded them, unzipped the folders, and placed them back into the software after deleting all of the old ones and it worked!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.