No track clearance whatsoever on pcbnew!


Im new to pcb design and very passionate towards learning and becoming very good at it one day. I also like to stay open source and KiCAD is the best choice.

So I created a not-so-complex circuit the traditional way–drew the schematic, associated footprints to the components, generated the netlist, opened pcbnew, read the netlist, did a little placement, drew filled zones and then I routed some tracks.

The problem that Im having is that when I view my circuit in 3d viewer, there are no spaces between tracks(clearance should I say) and every track just dives in the filled copper zone which is an absolute mess of course.

Is there some setting that Im missing here or some thing Im doing completely wrong?
I would be much obliged for any help.

KiCad doesn’t automatically recalculate filled zones on it’s own. There are a couple ways to recalculate the zones while in PCBNew. First is press the “B” key. Second is run a DRC. Third is export to gerber with recalculate zones option checked. For your current issue either the first or second would probably be best.

Just out of curiosity, are you on v5 or v4?

1 Like

Thank you for you kind and quick reply. I tried the first two methods to no avail.
DRC returns no problems. I attached the images so that it might give a better insight regarding the issue

I also just noticed that it removed some part of the copper from bottom left altogether!

In 5.0 you can View->Flip Board View temporarily to make it easier to compare with the 3d representation.

Then use these buttons
to change how the zones are shown in the board editor. The hatched outlines are not the final outlines. If you have a GND zone it covers all the GND tracks. With the upmost of the three buttons you can see how the zone is really filled.

Awesome! Point me out if Im wrong but I think everything is just OK. By taking a look at it the way you proposed, it seems that the traces that need to be separated are in fact separated from the rest of the ground or pwr plane. Its just that theres no other traces(Im not there yet :smile: ) that it should separate from the supply ( pwr & gnd) plane. I could be wrong, heres a look from the front with filled one shown.

And ya im using KiCAD 5.0.0

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.