No symbols after compiling from source

I’ve compiled KiCad from source as described here:
but I used “5.0” as the branch instead of “master” (master compiled 6.0, but I don’t want to be that bleeding edge, because I use it for production as well). Then I cloned this repository:

Then I specified the cloned directory in Preferences->Configure Paths->KICAD_SYMBOL_DIR. When I create a new project now and open the schematic, then click on “Place Symbol”, the list is empty. How do I specify the symbols directory? And maybe would be a good idea to add all the necessary steps to the build from source documentation. Do I need to add to clone and specify the footprint and 3D packages paths, too?

The environment (or path) variable is the unimportant part. You need to add the libraries to the sym-lib-table. Use the library managers for that. They are found in the preference menu of eeschema and pcb_new.
For the footprint lib there is a topic in the faq: How can i install a specific version of the footprint library?
In kicad 5 symbol libs are handled similarly.

I think my problem was that there was an old installation of fp-lib-table in /usr/local/share/template. When I started Eeschema, it asked to create a new global symbol library table (I deleted ~/.config/kicad ), and the recommended option was to copy the (wrong outdated) default global symbol library table. This resulted in paths like $(KICAD_SYS_SYMBOL_DIR)/74xx.lib but the KICAD_SYS_SYMBOL_DIR environment variable is outdated and not set.

So this is what I finally did, just in case someone has the same problem:

  • delete old configurations and templates etc.

rm -rf ~/.config/kicad
rm -rf /usr/local/share/template

  • clone all these repositories:

git clone
git clone
git clone

  • start KiCad. When opening a circuit diagram with Eeschema, on first start it asks to create a new global symbol library table. The first option to copy the default global symbol library table is disabled, because there is no template. That’s ok, choose “Create an empty global symbol library table”.

  • then in “Preferences->Manage Symbol Libraries->Browse Libraries…” add all lib files from your cloned kicad-symbols directory (all libs can be selected at once).

  • when you open a board the first time, Pcbnew says that you have to configure the footprint library table.

  • then in “Preferences->Manage Footprint Libraries->Browse Libraries…” you could select each library cloned in the kicad-footprints directory but looks like this time you can’t select all *.pretty directories at once. You could add it all one by one, very tedious. What I did: copy the file fp-lib-table from the cloned repository to your config directory:

cp ~/kicad-footprints/fp-lib-table ~/.config/kicad

  • this uses the KISYSMOD environment variable to reference the directoy where the footprint directories are. So in Pcbnew, select “Preferences->Configure Paths” and change the KISYSMOD directory to your cloned directory. And while you are there, change also the enviroment varialbe KISYS3DMOD to your cloned kicad-packages3d directory.

All these steps look a bit complicated and not consistent (you can’t select multiple directories for the footprints, compared to multiple file selections for symbols). And unlike the fp-lib-table in the footprints repository, I couldn’t find a lib-table file in the symbols repository, otherwise this could be copied as well. Not a big problem, because this happens only if you compile it from source (I guess), but would be nice to make it easier and consistent, and to add the instructions in the build instruction page.

Yes you can. (Works the same as for symbol libs) But there are other directories in the middle that you must exclude (directories that do not end with .pretty) If you include them in the selection the operation will fail. (Crtl + leftclick can be used to selectively exclude directories)

Thanks, this works, too. I think in KiCad 4 this was different, there was some overly complicated library wizard. So far I like the changes for KiCad 5, good work.

The way you used also worked in kicad version 4. But kicad 4 also had a so called library wizard that could be used to access the github libraries all at once. (This got removed as we now no longer suggest the use of the github plugin. In fact the new version 5 libs are incompatible with that particular plugin. This is the reason why new installers now also install local footprint libs.)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.