No Power Pin Nets on 74HC Footprints

I am using a 74HC14 footprint from the library. When I try to route tracks on the PCB no connections can be made from +5V to pin 14 and GND to pin 7 of the device because these pins have not been assigned to any nets. The hidden pins icon at the left side of the Eeschema window does not appear to do anything. In a previous topic it was suggested to use the 74AHC1G version of the schematic symbol and use the same reference designator (e.g. U1). First, this does not work because when trying to assign footprints, I get an error that two devices have been designated as U1. Second, the 74AHC1G version of the schematic symbol shows an inverter with pin 2 as input and pin 4 as output. This is incorrect but may be irrelevant because the I/O pair pins of the inverters in this IC device are 1-2, 3-4, 5-6, 9-8, 11-10, and 13-12. I have also tried to edit the footprint but cannot designate pins 14 and 7 as 5V and ground because the field Net name is greyed out. My Internet search for answers has come up empty. How do I tell the footprint (and the netlist) that pin 14 is +5V and pin 7 is GND? This problem appears to be the same for all 74xx series ICs.

The 74HC14 is not a footprint, it’s a schematic symbol. Unit G has the power connections. If you add a Unit G to the schematic you can wire it to the power nets.

OK, I did that and wired +5V and GND to it at the nodes indicated by small circles. KiCAD makes me give it a reference number other than U1 when I save the schematic and try to update the Netlist File, so I name it U3. This action creates an additional footprint that KiCAD wants me to place on the PCB. I tried superimposing on the footprint U1 but (I don’t even know if this is what I am supposed to do) but after superimposing I noticed that the footprint has assigned +5V to pin 5 instead of pin 14 and has assigned GND to pin 3 instead of pin 7 even though it knows that the IC is a 74XX14. I am stuck here.

Handling of multi unit symbols is part of Tutorial: Introduction to PCB design with KiCad version 5.1 (Getting Started) (I made it part of the second schematic section as it is a bit more advanced than a simple symbol)

Also note that there is additional information in the following layout section (there i explain how to change units around)

I don’t use KiCad libraries and in my libraries I don’t use symbols with separate unit for power connections (yet) but I’m sure that you are not expected to superimposing two footprints one over another. If that symbol has separate unit for power connections than it had certainly to have the same element name as other units of your IC and then it will be one footprint at PCB.

Thanks to all for the kind replies. I solved the issue by using a footprint for another device from the 7414 family that was a multi-unit symbol and included the power/GND nodes.

Hello Kend,

I know that your issue is resolved, but this piece of advice might help you in scenarios in the future. So when you are placing the 74HC14 schematic symbol from the library, please make sure that you place all the 7 symbols associated with it. Basically, this IC consists of 6 inverters, GND, and power pins. These are available as 7 different symbols, all of which need to be placed individually on your tool. Only then the connections will be enabled. Make sure you connect the same footprint to all of these symbols. Images are attached for your reference.