No PCB footprint libraries are listed in the current footprint library table


#1

Hello…

I’m new to Kicad and I was building my small schematic and when somewhere in the middle I was looking for symbols for a simple on/off switch I was not sure what I was doing and downloaded some files into a folder but somehow that ended up in some errors when I tried to assign footprints (Cvpcb) to my schematic:

So I decided to try to revert to the previous state and I end up deleting all footprint libraries going to Preferences->Footprint Libraries in CvPCB and removing one by one.

Then I realised I might have done even worse (I guess) so I search how to install default footprint libraries in Google and installed the ones from official site in Github but even so when I try to load CvPCB for my small project I still get this error:

After I click OK there I get this:

If I click “Yes” I get a new error that I think it is because I created a new symbol and there is no footprint associated with it.

But how do I get rid of the 2 previous error messages?

Thanks
Psy


#2

What kicad version, what operating system, how did you install kicad?


#3

Oh I’m sorry I mised that info.

I’m using Debian 9 and Kicad version

This is Debian 9 repository version of kicad.


#4

First check if there is another kicad package then the one you installed. (There might be a kicad-library package or something similar. use the search function of your package manager with the search text *kicad*)


If there is nothing then you might need to manually install the libs. Some details can be found here: How can i install a specific version of the footprint library?

Before you go this route check that there is really nothing in /usr/share/kicad/modules/
If something is there, remove the “/” at the end of the KISYSMOD environment variable. (Editing environment variables is done in the kicad main window -> preferences -> configure paths)


#5

Ok, so for the first part of your post, I used:

dpkg --get-selections *kicad* (back slashes to escape ‘*’ are hidden when I click save the post)

and this returned only

kicad
kicad-common

As for the second part, the folder /usr/share/kicad/modules/ has a list of files all ending with ‘.pretty’ extension.

I’m not sure if these files are there because of what I tried to download when I was searching for switch symbols or if they are there because when I tried to revert the problem I installed the footprints from github link as I explained in my first post!

Should I then delete all these files inside this folder? Or just remove the ‘’ from that environment variable?


#6

Depends. Are the .pretty folders inside the folder the same as kicad the ones kicad lists in the error message?

Also what github libs did you install and how exactly did you do it?
Github also already has kicad 5 libs that are incompatible to kicad 4.

Read my linked FAQ post and make sure you understand what i explained in there.


#7

Ok, this is not going to be easy, I know and I’m sorry for the mess.

The picture showing the ‘.pretty’ errors in my 1st post was after I searched google for symbols for switches. Then I have downloaded those ‘.pretty’ files from Github into my project folder. Then I went to main kicad window -> Tools -> Run Library Editor then in new window I went to Preferences -> Libraries and I added to both ‘Component Library Files’ and ‘User Defined Search path’ my project folder.

After that, when I tried to rund CvPCB, I got those errors in picture from post #1.

Then I googled about adding and removing footprint libraries and I went again to main Kicad Window, Run Eeschema -> Tools -> Assign Component Footprint and after clicking ‘OK’ on that error window about ‘.pretty’ folders, I went to Preferences -> Footprint Libraries and clicked on “Remove” to all libraries that were listed there one by one ending up with this blank window:

After this I searched how to install default kicad footprints and I ended up doing the following:

1 - In Cvpcb window, go to Preferences -> Footprint Libraries
2 - Append with Wizard and select ‘rom repo: https://github.com/KiCad
3 - Click next until process is complete.
4 - Restart Kicad

After this, the 1st post picture of errors were gone but started to get the 2nd and 3rd error messages when running CvPCB.

As of your question about folders of message about ‘.pretty’ folders, I have downloaded those files into my project folder and error messages of 1st post are not the same.

I’m going to read your FAQ now!


#8

Ok, I think I have solved the problem after reading your FAQ. I’m not sure if Github ‘.pretty’ libraries are the same version as the ones I have in /usr/share/kicad/modules/’ but I went to the Library wizard and pointed it to this ‘/usr/…’ folder and errors are now gone!


#9

I think you can use Debian backports for a more current version of KiCAD last I checked.


#10

Thanks Hermit… I’ll add it to my sources.list!


#11

In your first screenshot I see some references to:
/build/kicad-OldpkC/…/kicad_plugin.cpp

Have you been building KiCad yourself lately?
Could you have a conflict in configuration files between different KiCad versions?
That seems to be a common source for problems.

You also seem to have caused (most of) your problems yourself.
Why not simply a complete uninstall and re-install KiCad?

I am also running Debian here:
paul@dualcore:~$ uname -a
Linux dualcore 4.15.0-2-amd64 #1 SMP Debian 4.15.11-1 (2018-03-20) x86_64 GNU/Linux

And the KiCad Version I get from Debian’s package manager is:
Application: kicad
Version: 4.0.7+dfsg1-1 release build
wxWidgets: Version 3.0.3 (debug,wchar_t,compiler with C++ ABI 1011,GCC 7.2.0,wx containers,compatible with 2.8)
Platform: Linux 4.15.0-2-amd64 x86_64, 64 bit, Little endian, wxGTK
Boost version: 1.62.0
Curl version: libcurl/7.58.0 OpenSSL/1.0.2n zlib/1.2.8 libidn2/2.0.4 libpsl/0.20.1 (+libidn2/2.0.4) libssh2/1.8.0 nghttp2/1.31.0 librtmp/2.3
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_WXPYTHON=ON
USE_FP_LIB_TABLE=HARD_CODED_ON
BUILD_GITHUB_PLUGIN=ON


#12

kicads error messages are just strange. (A lot of them include more developer relevant information then user information.)

That’s a really harsh assumption to make.

And your proposed fix is not really a fix per se. (Re installing kicad will never ever fix the fp-lib-table in the user profile!)

A better way how to deal with this is to inform the user what the systems are they deal with such that they can understand why it broke. (As he already stated his problem is fixed it was not really necessary to answer in such a way.)


#13

Hello…

I’m not sure if I have ever tried to compile Kicad by hand myself. Anyway, I didn’t have these problems before!

My systems is:
Linux narayan 4.9.0-6-amd64 #1 SMP Debian 4.9.82-1+deb9u3 (2018-03-02) x86_64 GNU/Linux.

I think the problem is now over. At least so I hope!


#14

Well, maybe problem is not solved yet.

I have been able to clear those errors and actually populate that fp-lib-table file as shown below:


#15

But even after this, when I run Pcbnew and read the netlist file, I get a bunch of errors saying "no footprints exists even after I have assigned them before as shown below:


I know some components have no footprint associated yet but that’s the next step! Even so it was supposed the netlist to be able to read with only 2 or 3 errors.


#16

The errors after trying to read the netlist from Pcbnew are show below:

Why is this happening? What am I missing?


#17

Did you save the assignment of the footprints and the schematic before you exported the netlist?


#18

Can’t be sure about that, but I think I have exported the netlist before the footprint assignment!

So if I did this in the wrong “chronological” sequence, what is exactly the correct sequence of events?

Draw schematic, then assign footprints and only after footprints I go back to Eeschema and generate the netlist?


#19

Ok, I went back, saved the netlist again and went again to footprint and now almost all errors are gone but a few!

The errors related with the 7805 voltage regulator might be due to the fact that I assigned the wrong footprint to it. I searched for symbols and footprints in snapEDA site and tried it and probably it’s not the correct one! How can I remove a footprint already assigned to a symbol?


#20

You might want to take a look at this FAQ article: How can i assign a footprint to a symbol?

It does not directly tell you how to remove a footprint assignment. But i think the information given in it will be enough to figure it out on your own.