No parts or nets shown in PCBnew


I’m a newbie to KiCAD but used other systems before. I tried googling but did not find any help yet:

I created a very simple dummy project containing some C, R, D that are connected but don’t form any useful circuit, it is just for testing. I assigned footprints to the single parts and these are also available in the schematic again.

I then created a setlist and examining this in a text editor looks fine, parts, names, footprints are all contained.

When I start PCBnew then I get an empty sheet, there are not parts, no footprint is visible, nothing.

This behavior is different to what I’ve seen in tutorials, as I see it the footprints should be directly visible. I’m stuck here and don’t really know how to proceed. It must be some really easy beginners mistake as it seems nobody else has this problem.

I don’t get any error message shown.

I run standard KiCAD 4.0.7 on a Mac (all other PCs busy at the moment).

It would be great if anybody could give me a hint here.

Thanks for any hints,

You have to read the netlist in the board editor. See e.g. the Getting Started Guide:

1 Like

To add to what @eelik already wrote:

In kicad 4 you need to export a netlist from eeschema. (top toolbar or in the tools menu)
After that you can import the netlist from within pcb_new (Again top toolbar or tools menu)

In kicad 5 you will also find a tool “update pcb from schematic” that does all of this with kicad internal data structures.

1 Like

Thanks a lot, now it works. This was the problem.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.