No ground plane connection on component ground


#1

Hi,

i’am using a microphone component in my design that have an enclosing ground connection. When doing a filled zone to have a ground plane, the microphone footprint ground does not connect. I have tried multiple configurations in the filled zone, with no success so far. Any idea ?


#2

Check the pad settings. Is it possible that they are set to you have set it to Zone connect = None?

In addition, it looks a bit strange that you have two nets in listed inside the pad. (One normal GND and one with @ plus a number).


#3

Yes, start by verifying that all of the pin NUMBERS on the schematic symbol correlate correctly to the pad NUMBERS on the footprint. Are all of those ground pins visible on the schematic, or are some of them hidden?

Do the ground pins on other components connect correctly to the fill zone?

Dale


#4

Can you publish the footprint file here? Or even the whole board file?


#5

I’m trying to reconcile how the clearance lines for your ground pads don’t line up with your ground copper. Is that copper in the footprint? I’m wondering if it is why you aren’t getting any thermals to your ground plane.


#6

That’s why I asked for the footprint…


#7

Copper zones have their own clearance settings. If it is setup to be larger than the pad (*) clearance then it will be farther away from the pad then the pad clearance would suggest.

*) With pad clearance i mean the clearance that is either set on the net level or footprint/pad level.


#8

Hi,

the footprint was downloaded from SnapEDA (search INMP621). The footprint is made from a shape in the copper layer and GND pads (labeled GND@1 to GND@11). I have tried removing most GND pads but two and use “Create pads from selected shapes” to get only two pads. The issue that i have now is that the copper fill gets everywhere (enclosed image) and does not generate thermal reliefs.


#9

Custom pads to not support thermals. You have the choice of solid connection or none. With none selected you can make the spokes yourself using normal traces.


#10

When pad is custom pad?
KiCad 5.01. I opened footprint editor and loaded first footprint I found (some battery). I have added new pad and entered its edition. I see “Custom Shape Primitives” tab.
If there will be anything there the pad will be “custom pad” ?
There are some buttons (like “Add Primitive”) but all are inactive. So how can I do custom pad?


#11

A pad is custom when you select custom as its shape :wink:

And yes this is the type of pad that can use custom shape primitives.

If you select a polygon (or other primitive) and a pad, right-click and select create pad from shapes then it will be a custom pad. (This is the way to really create one. Setting the shape to custom and adding primitives manually is not really an intuitive way to do it.)


#12

Thanks.
I am preparing myself to move to KiCad so collecting ‘know-how’ ‘how-to-use’ it.