No grid in footprint editor

Hello!

Everything is in the title. Does anyone know how to show the grid? I mean, other than trying to
switch the grid using the icon. I thought the color might be a problem, changed it but it doesn’t
make any change.
Thanks for any hint.


Application: KiCad

Version: 6.0.0-rc1-unknown-e56e61ffb5~144~ubuntu21.10.1, release build

Libraries:
wxWidgets 3.0.5
libcurl/7.74.0 OpenSSL/1.1.1l zlib/1.2.11 brotli/1.0.9 libidn2/2.3.1 libpsl/0.21.0 (+libidn2/2.3.0) libssh/0.9.6/openssl/zlib nghttp2/1.43.0 librtmp/2.3

Platform: Linux 5.13.0-21-generic x86_64, 64 bit, Little endian, wxGTK, ubuntu, wayland

Build Info:
Date: Nov 23 2021 09:49:28
wxWidgets: 3.0.5 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.74.0
OCC: 7.5.2
Curl: 7.74.0
ngspice: 35
Compiler: GCC 11.2.0 with C++ ABI 1016

Build settings:
KICAD_USE_OCC=ON
KICAD_SPICE=ON

try following places with grid-relevant-settings:

  • grid on/off (icon on left tool-bar)
  • grid-spacing (pull-down-menu at top toolbar).
    Inside the footprint-editor: take care of the relationship of grid-spacing<–>size of view-window. SMD-footprints are usually small - so to see the grid-points you have to choose a small grid (for a first try: set 0.1mm)
  • with footprint-editor open: preferences–>footprint-editor–>Display-Options:
    grid-thicknes+grid-spacing

You can also play with these options in the normal board-editor-view. If the grid works there it should also work in the footprint-editor.

1 Like

Hello!

Thanks for your reply. For some reason, grid was set to dots, which makes it close to invisible with my color setting. It works now!

This happens to me also when regularly downloading new versions of 6.0

Another thing I noticed: In PCB, “Presets” (near the bottom of the RH Appearance column) after installing a new 6.0, shows -----.
I was caught out once (can’t remember about what) until I changed that to something else.
Worth checking that also after a new 6.0 install.

Cheers, Jan