No footprint selected

Application: KiCad
Version: (5.1.6)-1, release build
Libraries:
wxWidgets 3.0.4
libcurl/7.66.0 OpenSSL/1.1.1d (Schannel) zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.1.1) nghttp2/1.39.2
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.71.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.66.0
Compiler: GCC 9.2.0 with C++ ABI 1013

Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=OFF
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=ON

Been Using Kicad as an undergraduate student for well for 2 years now and this is the first time I’ve encountered a problem like this.

Whenever I try to add a footprint using the footprint editor I just can’t seem to be able to select it.

The result is the same in the footprint editor as well.

After noticing this I opened one of my previous projects and found out that everything works fine there. The problem only persists in my current project.

I hereby certify that I am not simply asking someone else to design a footprint for me.

This is an auto-generated message that is in place on the “footprints” section of the KiCad.info forum. If I remove it and ask for a footprint to be designed anyway, I understand that I will be subject to forum members telling me to go design my own footprint or referring me to a 3rd party footprint site.

KiCad V5.1.6 is almost a year old, and there have been quite some bug fixes after that. Current is V5.1.9. Maybe consider an update? (It’s free).

My first guess is that you have links to the libraries (in fp-lib-table) but there is something wrong with your environment variables, to it can’t find the complete path to your libraries.

I have both KiCad V5.1.9 and V5.99 installed.
My environment variables look like (From: KiCad / Preferences / configure Paths)
image

Notes:

  • I run linux, so my paths are different.
  • You can try to use a program like meld merge to attempt to find configuration differences between different projects.

Thanks for your reply.

This is a Screenshot of my environment variables:

I don’t think it’s an issue cause it is comparable to yours and I went to the location and found everything in order.

Are there differences in these paths if you compare them to a working project?

Can you verify with a file browser that the files are actually present in the locations pointed to?

It’s just a guess, but it’s possible your other (older?) projects use older libraries (for exmple from KiCad V4, recognizable by plural names).
This may have relevant info:

and:

It’s working! (at least for now)

I did verify the path by going to the location and checking the files.

The other working projects and the project with the mentioned problem have the exact same paths.

However, when I copy pasted the paths from a working project and copied it to the malfunctioning one, it started to work again.

Don’t know if it’s a temporary fix or I’ll encounter this problem again, but for now it’s working without any issues.

Thanks a lot!

Is there any chance you edited those variables in any way?
A simple space in the wrong place may have made the path invalid.

1 Like