No footprint for TQFP-32


#1

Hey, when i run CvPcb to assign footprints i get the following error for my schematic using an ATMEGA16U2:

The following errors occurred attempting to convert the footprint assignments:
Component ‘IC1’ footprint ‘TQFP-32’ was not found in any library.
You will need to reassign them manually if you want them to be updated correctly the next time you import the netlist in Pcbnew.

Note that in my modules directory I found a file /usr/share/kicad/modules/Housings_QFP.pretty/TQFP-32_7x7mm_Pitch0.8mm.kicad_mod
There was also a topic long ago (2015) about this it seems, but not helpful to me.

I’m quite confused since this mcu was available in the components list by default and not to be considered exotic. Why dows KiCad list it but does not provide any footprint? Is TQFP-32 that unusual? Since I’m designing my first board and try to stick to standard parts, im very reluctant towards creating the footprint myself. But maybe someone here can provide a quick solution.


#2

The kicad library does not claim to include every possible part.

And even if there is (or once was) a footprint for that part there is an additional problem:
In kicad 4.0.x footprints are downloaded on demand directly from github but the symbol libs are bound to the kicad release. (Unless the user does either install local footprint libs or updates the symbol lib.)

This will result in footprint libs being out of sync with the symbol libs. That means if the symbol has a footprint assigned but this footprint has been renamed in the new lib, then the footprint field of the symbol will point to a no longer existing footprint.


Solution: Make sure to run local footprint libs of the same release as your symbol libs.
A tutorial for that can be found in the FAQ section (It handles the footprint side of things. The symbol side is harder so i suggest to simply install the footprints of the same release as your kicad version.)


#3

Hi @dwidd2,

The TQFP-32 was most likely renamed to TQFP-32_7x7mm_Pitch0.8mm in a newer version of KiCAD to more uniquely identify the package.

Simply re-assign the footprint by selecting TQFP-32_7x7mm_Pitch0.8mm from the Housings_QFP library in CvPCB and re-export the netlist.

Regards,
Niels.


#4

Thanks for your answers!

Simply re-assign the footprint by selecting TQFP-32_7x7mm_Pitch0.8mm from the Housings_QFP library in CvPCB and re-export the netlist.

This solved my problem. You may wonder, as this was essentially suggested by the error message I got, but I had to figure out some time how this re-assigning works. Problem was the standard filter for keywords, which results in no assignments shown for ATMEGA16U2, had to deactivate that first. But now everythings fine, thanks again.


#5

You should report the filter failure as a bug in the GitHub libraries.
All of the MCU_Atmel parts seem to be calling TQFP44 etc, which won’t work with the new footprint naming


#6

I created an issue about that. https://github.com/KiCad/kicad-symbols/issues/300


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.