No connections between symbol and footprint

I have a schematic, drawn by a client, that includes a 76 pin module. I also have a footprint; a .mod file. Using file>import>footprint, I successfully added it to my library. But the “update pcb from schematic” tool says it cannot find it. Using the “add a footprint” in the right tool bar allows me to manually place the footprint, but no connections show between symbol and footprint.
Under preferences, the footprint is there with its .mod extension. All the other libraries have the .pretty extension, but they are for multiple footprints.
On the pcb with the footprint manually placed, I added the correct ref, and I can cross select pins between the symbol and footprint, but no connections show up.

Ideas?

TIA bdh

Strangely, I haven’t had a chance to use V6 in any meaningful way yet. Did you associate the footprint with the symbol in the schematic?

Hi Hermit - I’m not exactly sure what you mean here. The schematic was drawn in 6.0.2 by a client, who also provided me with the footprint. I am using 6.0.7.

If you hover over the symbol in the schematic and press “e” you should see the dialog above. This is where you associate the footprint with the symbol so that the PCB editor knows the connection.

Did you import this into a personal library? Is that library active for this project?

Basically.

  1. Make sure the footprint is associated with the symbol.
  2. Make sure the library you imported it to is visible to this project.

I’m assuming 2 is OK since you can add the footprint. What you appear to be lacking is a connection between the symbol and the footprint. If the client supplied the footprint separately
they may not have associated it in the original schematic.

Also, what is the part? I’m assuming if it was supplied separately it isn’t a standard Kicad default library part, but, let’s not make that assumption.

OK - yes, the footprint is associated in that dialog.

I imported it into the Global Libraries tab, and it is visible.

No it is not a standard part. It is a 76 pin module called a “Nucleo” - much like an Arduino or Raspberry Pi. I’m not sure where he got the thing.

Last thing I know to try. From that dialog, click on the footprint. At the right you can click on the library icon. You can search the footprint name. If it shows up, click on it. If it doesn’t then the library isn’t visible to the project. I doubt this since you can add it manually. There might be a misspelling or it might be checking a different library location. After that, I’m stumped.

Search shows different variations on github.

When I click on the library icon, it responds with a dialog "The current configuration does not include the library ‘Nucleo’. Use Manage Footprint Libraries to edit the configuration. And it opens the library, and the library is present, but not capitalized - nucleo. Is it case sensitive? It won’t allow me to change it.
Well, that was interesting. In Manage footprint libraries I was able to change the case of the ‘N’. Now the footprint doesn’t appear in the library. The footprint .mod file is in a folder on the desktop. Yet it claims it can’t find it.

Apparently this part came from SnapEDA. I’m going to try to get a matched set from them. I’ve spent too much time on this already.

Thanks for your help.

This should take only Two minutes - Goal: verify the process-steps by using simplified Symbol/Footprint/3D-Model

Attached: 3D-Model (M3x6.step)
M3x6-Screw.step (364.7 KB)

In PCB, Create a New Footprint:
• A Circle with a Cross on SilkScreen Layer
• In the Footprint Properties Panel,3D-Models Tab: link the 3D-model (shot1)
• Save

Eeschema:
• Create a New Symbol (shot 2)
• In the Symbol Properties panel, link the Footprint (shot_3)
• Save

• Now, in Schematic, place the new Symbol into Schematic, Annotate
• Save

• Now, in PCB, Update_From_Schematic
• Save

All should be good with process, symbol and footprint

Errors? Ensure Paths are set and verify the 3D-Model settings in the Footprint Properties panels: If you see a RED icon, you got a path and/or filename problem

Be aware: Not all 3D-Models & Footprints from the outside-world (meaning, don’t fully trust what others post as a resource)

Shot_1
shot_1

Shot_2
shot_2

Shot_3
shot_3

Shot_4
shot_4