No confirm button in the device list

Ho do I put a component in the shematic without a confirm button?

You have opened the symbol editor. This is the tool to change symbols or to create new ones. The add symbol button is in the right toolbar not in the top toolbar. (can also be reached with “place->symbol” or hotkey a)

You might be interested in the beginners tutorial i wrote Tutorial: Introduction to PCB design with KiCad version 5.1 (Getting Started)

On the other hand there really is a dialog for choosing a symbol - and likewise for footprints - which doesn’t have the OK button.

image

Solution: double click the name in the list. I think this is some legacy thing, I doubt it would be done this way if designed from scratch.

Why not mak a confirm button in both, the creator and the add list?

A conform button makes no sense for the intended use of the symbol editor. To reduce confusion differentiating the buttons might be the true option.

Double clicking works quite easily.
I also do not understand why there is a screenshot of the Symbol editor.

If I just press a from Eeschema, I get:

And if I then double click on the blue line for 14529 it gets put into the schematic.

You can also use the cursor Up/Dn and page Up/Dn keys go go through the selection and press enter when you have a symbol.

The easiest and fastest method however is to copy a symbol if it’s already on your schematic. Just hover over any resistor, capacitor, power symbol etc, and press c to make a copy of it, and then place it somewhere.

Tip:
If you assign a footprint to a symbol before you copy it, then that footprint link is also copied, so you only have to do the footprint lookup once for each type of symbol used.

Because the symbol editor and the add symbol dialog have the same button design (symbol editor is in the top toolbar while the add symbol dialog is in the right toolbar). Which lead to the user confusing the two.