No colors menu in 3D viewer preferences (KiCad v8.0.2)

Application: KiCad 3D Viewer x86_64 on x86_64

Version: 8.0.2, release build

Libraries:
	wxWidgets 3.2.5
	FreeType 2.13.2
	HarfBuzz 8.4.0
	FontConfig 2.15.0
	libcurl/8.8.0 OpenSSL/3.3.0 zlib/1.3.1 brotli/1.1.0 zstd/1.5.6 libidn2/2.3.7 libpsl/0.21.5 libssh2/1.11.0 nghttp2/1.62.1 nghttp3/1.3.0

Platform: Arch Linux, 64 bit, Little endian, wxGTK, X11, , tty

Build Info:
	Date: Apr 28 2024 16:02:51
	wxWidgets: 3.2.4 (wchar_t,wx containers) GTK+ 3.24
	Boost: 1.83.0
	OCC: 7.7.2
	Curl: 8.7.1
	ngspice: 42
	Compiler: GCC 13.2.1 with C++ ABI 1018

Build settings:
	KICAD_USE_EGL=ON

Can you expand a little on that? What did you expect to see and what are you seeing instead?

Color selection in the 3D Viewer is available in the Appearance panel on the right side of the 3D Viewer window.

If the Appearance panel is not visible it can be toggled on/off by clicking on the right most icon in the toolbar at the top of the 3D Viewer window.

In the Appearance panel, double click on the color you want to change.

I ‘think’ @Bog is referring to the 'Color’s selection label that seems to be missing in posted panel above - screenshot of mine below…

1 Like

Interesting. I don’t have the “Colors” option (KiCad 8.0.2 on Windows 11) in 3D Viewer Preferences. Maybe it was moved to the Appearance panel in Version 8? I don’t have any earlier versions installed to check.
3D_VIEWER_PREF

For me, Preferences / Schematic Editor / Colors and Preferences / PCB Editor / Colors show a color selection menu on the left, and a preview on the right:

Preferences / Symbol Editor / Colors shows a mostly empty window:

Preferences / Footprint Editor / Colors shows the color selection, but no preview:

I guess these were added later and the code is just not finished yet and buggy.

Application: KiCad x86_64 on x86_64

Version: 8.0.2-8.0.2-0~ubuntu20.04.1, release build

Libraries:
	wxWidgets 3.2.2
	FreeType 2.10.1
	HarfBuzz 2.6.4
	FontConfig 2.13.1
	libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

Platform: Linux Mint 20.3, 64 bit, Little endian, wxGTK, X11, xfce, x11

Build Info:
	Date: Apr 28 2024 21:38:36
	wxWidgets: 3.2.1 (wchar_t,wx containers) GTK+ 3.24
	Boost: 1.71.0
	OCC: 7.6.3
	Curl: 7.68.0
	ngspice: 42
	Compiler: GCC 9.4.0 with C++ ABI 1013

Build settings:

I am new to Kicad (switching from easyeda), so as I was exploring I wanted see 3d view of my board which worked but now I wanted to change the board color, after searching on internet I came across this Change board color, lighting properties and more. but when I looked in mine it wasn’t there. I tried to change color of soldermask in new theme but that also failed.
So how can I change the color of board ?

Thank you, I was able to change board color in appearance (earlier I was double clicking the layer text label instead of that colored box icon :person_facepalming: :person_facepalming: )

I created an bug report for the very old video on the KiCad website. The video is from 2015 and pretty much obsolete. KiCad has made a huge amount of progress over the last 8 years.

1 Like