No 4xxx or 74xxx logic libraries showing in Schematic editor

Hi All,

I was trying to place a 4049 CMOS part in the schematic editor, but the library is not showing. ( Nor for that matter, is the 74xx logic ic’s lib)

I am running Version 5.99.0 on MacOS.

I see all the other libraries but it seems none of the ones starting with a number …

In Finder I go to the “Applications Support/ kicad/ library” folder and they are visible there, but they just refuse to show up in Kicad …

(Actually I see a 4xxx.kicad_sym entry in path above … for the 4xxx series, can’t see any .lib files, has this changed?)

Any idea’s on how to debug this …


I do have the 4049 in KiCad-nightly V5.99:

And 74xx:

I have 5 libraries starting with a number listed in: Eeschema / Preferences / Manage Symbol Libraries / Global Libraries

KiCad does not search for libraries, and it only shows & uses libraries listed in the table above. If you add those libraries starting with a number to the library table, can you use them then?

Maybe it’s just a small hickup not worth spending much time on, if more (or all) mac users have this issue then it is a problem in the way KiCad is installed on mac.

(I run Linux myself).

Application: KiCad Schematic Editor

Version: 5.99.0-unknown-56f6e7cc17~117~ubuntu20.04.1, release build

	wxWidgets 3.0.4
	libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

Platform: Linux 5.4.0-66-generic x86_64, 64 bit, Little endian, wxGTK, mate, x11

Build Info:
	Date: Mar  7 2021 08:05:29
	wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
	Boost: 1.71.0
	OCC: 7.3.0
	Curl: 7.68.0
	ngspice: 31
	Compiler: GCC 9.3.0 with C++ ABI 1013

Build settings:

Sidenode: in nightlies the file names should end in kicad_sym not lib as they are already on the new file format. The files that one should have are the ones that are found in this gitlab repo


I had to manually add those libs with the Library Manager and now works fine. Must be a bug with MacOS that those don’t show up as being available …


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.